Track to makes object sink

Hi all, I made a track to (logic bricks) to make enemies charge at the player… but for some reason they sink slightly under the plane. The movement is controlled by a cube, and they’re all at the same level (height) :confused:
What could this be and how can I fix it???
Thanks! :yes:

Edit: The guy chasing the player is a rigid body

Is it that the track to is making the player sink, or perhaps something else (a motion actuator that you have connected, perhaps)? It might be that a motion actuator is interfering with the gravity of the character.

Yeah, I checked that. It wasn’t, it’s at the usual 0.10, nothings outta place. I played around with the damping, putting it to the max makes em not sink anymore :slight_smile:

I expect you’ve enabled 3D tracking. If the center of the enemy is above the center of the player it tracks to, it will angle downward when moving and clip through the floor.

lol I did it, and the object acted like a pogo stick or a car with hydraulics. Don’t worry about it though, the damping worked and the problem is solved :smiley: Thanks for the effort!