Tracking, strange background seq behavior

Hi there!

When I am in the Solid view I can see my tracked background image seq properly as a background (here overlapped by a plane):

But when I go to the Render (or Material) view, my tracked background image seq is projected over the plane, and it’s not visible as background:

In fact if I click “Show overlays” off, I just cannot see my background image seq anymore.

I have followed for two days a lot of Tracking tutorials, and I just can’t figure out why I cannot see the resulting tracked footage as a background (of course I have set this image sequence as background in my camera properties).

Any idea?? I am desperate, thanks a lot in advance.

1 Like

Have you tried setting the Depth to Front and playing with the Opacity?

Thanks for your answer. Yes, I think I tried and tweaked every possible parameter.
If I put depth into front (in every tutorial it’s in the “back”), then my 3D models stay behind, if you put opacity lower (in every tutorial they say to put it at 100%), the image becomes gray and looses presence.

Any other idea why my image is projected over the “plane” object instead of being as a camera background?

Looking into this further, I came across the following bug report which states the commit that caused this issue to occur:

A possible workaround might be loading the image sequence in the shader editor’s image node as an image sequence, and use that image sequence as the camera background, instead of the movie clip.

Oh wow! Nice to know I am not crazy.
Thanks a lot for the further research and for the link. I will try the workaround.


1 Like