Trackpad on Macbook Pro works differently from Trackpad on Imac with Blender


I have a new Imac with a magic trackpad. When working on the Imac i an drag two fingers up or down to zoom in or out. If I have selected loop cut, for example, dragging two fingers up or down will increase or decrease the loop cut count. Other tools work in a similar manner.

This is the way I want it to work.

I also have a new macbook Pro. On the macbook Pro using the trackpad works differently. Dragging two fingers up or down just pans the view up or down. When using loop cut, dragging two fingers up or down doesn’t do anything. In other tools, using two fingers to drag up or down does not change parameters either.

It looks like the settings in Blender and the settings on the trackpads are identical on both machines. Both macs are running the same OS version to. 10.7.3.

Has anyone seen this or have any suggestions besides getting an external mouse?


oh wow, can you really tolerate using it with the trackpad only?
When I’ve tried, on both a mac mini and a macbook air using 10.5 - 10.7 I’ve only ever had the two finger zoom.
I can only stand it for a quick check into a file. If I need to do something I have to reach for the mouse.
Like, to rotate the view you have to twist two fingers and you get a Z camera rotation. How do you get any other rotation, free gimbal?

Have you looked into your Mac’s System Prefs under the mouse or trackpad settings to see if there happens to be any difference or Blender specific additions to the default?

I find the magic trackpad to be just as easy for me to use as a normal mouse. I have emulate 3 button mouse in preferences checked and it works fine.

Now on the macbook, the way it works now, I find the traditional mouse easier to use.

The problem is that when I’m using the macbook, I’m usually using it in an area where I can’t attach a mouse.

I’ll try to see if I can reproduce your problem tonight.
I haven’t tried much with the magic Trackpad. Maybe my opinion is colored by using the macbook. I don’t like plugging in the mouse either, but it’s the only way I’m blending on my couch or mother in law’s kitchen table. :smiley:

So I just reproduced that problem.
on the Macbook, the loop cut count scroll to change amount of cuts is not the same as the desktop Magic Trackpad.
The loop cut count will not change with the two finger scroll, UNLESS you throw it, meaning, scroll fast and lift your fingers.
But that sucks, because instead of the 2 or 3 you want you get 29 or some large #.
i tried turning off inertial scroll in Universal Access Prefs, but that just stopped any scrolling loop count change.
not sure how to get around that.

yeah, this scroll thing sucks. I use fn+up/down for Loopcuts instead, or just press the number of cuts you want (ctrl+r, followed by number).