Transparency in Edit Mode (2.56)


I am trying to get an object to be transparent in edit mode. Through the use of a transparent material I got it to be transparent, but as soon as I enter edit mode it stops being transparent. Is there any way I can fix this?

The reason I am asking is because I set up planes with an image as texture as my backpanes, but now I can’t see them because my object is solid. When I set the mode to wireframe that doesn’t help either, as now I won’t be able to see the images anyway as they are no longer displayed.

For the object with the texture you could set X-Ray in the Object / Display settings
For the transparent object you could set the display type to be Wireframe in the Object / Display settings

Thanks for your quick reply. I must say I haven’t been very patient. As I am on a rather tight schedule, I decided on using background images instead. I like this less because they aren’t present in my perspective viewport, but because the there was a slight discrepancy between the results the two methods gave, I can’t just switch back now without that costing me a lot of time.

Still, I’ll be revisiting your answer once this project is done, as I would like to use the plane-backpane technique I am used to from using it in Max.