Transparency map isn't totally transparent [Solved, I think]

I’m haveing a bit of trouble getting this right. What I want is for explosion effect on the plane - I’m using a blend texture to get that effect - to gradually fade out to total transparency. Instead, I get this annoying ‘darkening’ effect which spoils the picture. What steps should I take to fix it?


you should show the screenshoot of your material and texture setings

Actually I think I found it, if I turn the Traceable option in the Render Pipeline sub-pannel off, then the problem goes away. Although this is probably not the best solution.