Transparent mesh in edit mode

Hello, everyone! I am modeling a car, and have noticed that when I am in edit mode, the mesh becomes partially transparent, showing what is behind the frontmost faces. This makes things kind of hard to see. I am in Solid display mode. I have attached a screenshot of the front of the car, and you can see the vertices and edges that are inside the engine area are visible and selectable. I have a mirror modifier (which is disabled) and a Subdivision Surface modifier (which is also disabled). I tried playing with the backface culling setting and other sorts of things, but am at a loss. Can anyone help?

Thanks!

Joe


Click here:

I am not sure if this is supposed to be on or off. Here is a screenshot. Sorry for the newbieness!


Joe

an interesting way to solve this, is to follow the instructions in post 2

If On/Off that above mentioned thing does not help, make sure this (marked red) is set to higher value.

Yes, that did it! I had my View Clip setting too low. Thanks Kaluura, Small Troll and Eppo!

Joe

this just solved my issue too.

But i really wondering why the heck this setting is acting on objects? So far i thought this setting does just set the clipping range of the Viewport, so why does it change the appearance of objects overall? IMHO this is a BUG! Any Ideas?

I can replicate this behavior by making a very, very tiny mesh. So I suspect the problem is related to the rounding of very large or very small numbers (due to the fact that each number is only a certain number of bits).

You’re right… found this on Blender Wiki:

Clip Start and Clip EndAdjust the minimum and maximum distances to be visible for the view-port.[TABLE=“class: note, width: 779”]

Notice
http://wiki.blender.org/uploads/thumb/f/f3/Exclamation_mark.png/25px-Exclamation_mark.png
A large clipping range will allow you to see both near and far objects, but reduces the depth precision.To avoid this…

  • increase the near clipping when working on large scenes.
  • decrease the far clipping when objects are not viewed at a distance.

When perspective is disabled only the far Clip-End is used, very high values can still give artifacts.This is not specific to blender, all OpenGL/DirectX graphics applications have these same limitations.

[/TABLE]

worth to check out the wiki once in a while :wink:

Yeah it is an OGL issue and it happens in one way or another in all apps. This is just Blender’s variety. Happens in all apps also with different artifacts when you have to far range set for very large scenes/objects.

OK I say all. Of course I have not used all of them. But in the 5 3D apps I used it does. And it is related to OGL.