Transparent Objects' Edges are Showing

I’ve got a compositing issue that I’m hoping someone can help me with. I tried Googling to find a solution, but I’m not exactly sure what the problem is. Here’s what I’m doing: I’ve followed this tutorial on how to composite Blender objects into a photo.

Everything has worked just like the tutorial said it should, with the ground planes becoming invisible and the objects casting shadows on them/the image. However, if I zoom in I can see black lines marking the edges of the planes. Maybe like halos? I tried making the planes really big, because I thought the shadows were getting in the way of the planes’ edges, but that didn’t fix them. I also added a cube onto the invisible ground layer, just as a test, and while it is invisible I can see its edges and that the plane under the monkey is casting a shadow on it. I’ve attached close ups of the problem areas in the render, and my node setup.

I don’t really know much about compositing, but I’m thinking maybe the Multiply node is doing something? It seems to be what makes the planes invisible.

I’m using 2.67b and I’m rendering with Blender Internal. The objects and planes do not have any materials or textures applied.

Try turning on Premultiply in alpha over nodes?

Turn on “Full Sample” and re-render.

Vvtszquk, that was it! All the lines are gone now. Thanks very much!