Transparent plane issues

So I am just starting to get a grasp on blender, but there is a good amount that still alludes me. I am going to try a more face intensive approach, as I know it will aleviate my problems, but am currious as to why this is happening so I might avoid it later.

I am currently trying to make several 2d partially transparent plane using a .png file, I followed several tutorials and have ended up with something that both Renders and (somewhat) works in the GE. My setup includes; in Texture Face tab Tex, TwoSided and Alpha are set, it is UV mapped, Map Input set to flat UV, and Map To is set at Col and positive Alpha .

However, if there is another transparency plane close, or the camera gets too close in the GE the farther plane will “bleed through” into the foreground plane, and a white background will appear where the transparency should be in effect, issue 1 and 2 respectively.

Issue 1 - the grass bleeds thro the 4 tree textures rotating around a local z axis, and they also bleed into each other
Issue 2 - the church gets the white boarder when the angle between the camera and plane is too acute.

I have looked for an answer extensively on this forum, via google and any other search I could think of, and am very sorry if I, like I have a nasty feeling I did, gave up merely a few threads too early.

Thank you in advance to anyone who can shed some light on this for me!


Is the ZTransp button active on the materials that have transparency?

The first one sounds like the alpha-sorting bug. Try using the Clip Alpha setting.

Is your world background set to black? Or is the world background white, with a black plane or skybox? If so, then it’s a camera clipping issue. Increase the end clipping value of your camera. If the world background is indeed black, then I’m not sure where the white is from without seeing the .blend file.

Thank you both for your responses. Magnum, you were right about the alpha clipping and I feel I would have never figured that out on my own as I was not sure what to look for to solve the problem. The second was a result of having z-trasp was turned off, which I spotted a couple minutes after posting. Toggling that immediately fixed it.