I’m just useing the cube that we start with. Click on matirials check transparency, slide alpha, preview changes the cube does not. I’m sure I’m missing a check box somewhere. What am I missing??

What you see in the 3D view port is not a live preview with Blender Internal render, witch you are obviously using. The result is only visible when you render your scene (F12). Some of the material settings are previewed in the preview of the material panel.

Oh OK. Let me rendor then. Thank you.

You can see some effects, like transprency, in the viewport if you change the view shading to textured (on the 3d view header) and in the Properties panel (shortcut N) under Display, change the shading from the default Multitextured to GLSL. Note that the result will not exactly match what you see when rendered.