"Trapped" inside Stencil Mode?


(Alejandro Cambra) #1

Hello! My first post here :wave:.

I have a problem when texture painting my model.

I was working on my project, texturing my object. All worked fine. But suddently, I don’t know what did I do exactly, brushes disappeared from my Tools tab and a message warning me about “Missing Stencil” showed up there:

Issue

The thing is… I didn’t even know what Stencil Painting was until looking up my error on Google! Don’t even know what I have done, or what should I do to fix this. Everything else is set up correctly (as I’ve already said, it all worked perfectly until now). I have my material attached, with a Texture Image node selected with my texture, the same texture selected in the UV/Image Editor and Cycles set as my rendering engine, as well as my model, obviously, properly unwrapped.

Hope someone knows how to help me :pray:.

Álex.


EDIT: I’ve tried to select a random image as Stencil Image to see what happens. Ok, now I’m inside “Stencil Mode”. The question now is: how I return to “normal” texture painting?


#2

If you simply unlink your image you should fall back to regular painting mode.


(Alejandro Cambra) #3

But my problem is I don’t see any menu apart from these:


EDIT: I’ve tried to reset the default interface, but the issue persists. What kind of wizardry is this?


#4

If you go into the slots tab what you see there? Could it be that you accidentally unlinked your UV map?


(Alejandro Cambra) #5

I’ve also tried those settings, but it was infruitful. These are the options I have available:

Issue%201

Issue%202

(I know the last screenshot shows the settings of the pencil, but just in case there is some weird option relevant to my problem over there…).


#6

Could you upload a .blend file? It would be easier to see what’s happening, you can delete your model from it.


(Alejandro Cambra) #7

Sure, here you have it:

Texture Paint issue - Missing Stencil.blend (534.5 KB)

I’ve created a simple cube and activated Texture Paint just to bring you right to the issue :slightly_smiling_face:.


#8

OK, so in the Slots tab go to Paint Mode, in the drop down menu choose Image, below that for the Canvas Image choose the image you painted on from the drop down menu and below that choose your UV map. Now go to the Tools tab, for the Stencil Image choose any image you can from the drop down menu, we just want to make warning go away. After this the brushes should show up, click on the sphere and select the TexDraw brush. If all went well now you should be able to paint on your model again. In case it’s still not working as expected let me know.


(Alejandro Cambra) #9

IT WORKED!! Thanks A LOT!! I’ve lost three entire days with this, and now I can continue working on my project. Gosh, how I hate to get stuck like this.

Once again, THANKS! :star_struck: :blush:


#10

You are welcome! :slight_smile: