Triangle add-on for Blender

Looks great!

Yes, I’m still around, but super busy with life at the moment… :confused: I do intend to revisit this though, when things settle down a bit!

amazing, do you mind sharing this?

1 Like

I am also very interested in this.

Woah, that’s intresting.

Thanks for the interest…

I am working to polish it up, but I keep implementing, so the dirty code keeps getting away from me – still have several issues to solve.

This was just something I did for myself, but I would love to share when I am at a good state – I have a whole cloth sim tools panel with a couple of different remeshing tools modified from original authors.

  • No, Jeacom, your work is interesting – you busted out your version overnight after seeing this – I love your work, and am trying to learn all I can from your coding when I have time.
1 Like

Hey all, I’m back…

I managed to port Tom’s original version to 2.80 today as a test before I try to port my modified version (when finished).

I only made minimal changes, so some of the flags enabled in my version are not enabled here.

But, I did add the interactive view-port usage, so you can make changes visually without having to redo over again.

Triangulate With Triangle for B2.80 :
mesh_triangle.zip (384.9 KB)

  • Caveats to working with Triangulate (Triangle) for those who don’t know :
  1. A closed (cyclic) curve is needed, and in Object Mode
  2. You can work from Top View or Front View, but working from FV requires either starting from TV and rotating 90 degrees to FV without applying rotation (which will hang and possibly crash Blender) – Or start in FV with ‘Align to View’ enabled for new creations (which sets objects to 90 degrees Global [X axis] - Do Not Apply Rotation)
  3. You can triangulate several outlines at same time individually, or as one outer object with internal objects as one object with use of Object Join
  4. Bezier curves are needed, so if you add other curve types, you must convert to Bezier – if from poly curve and you want your edges sharp, switch handles to ‘Free’
  5. For 2.80 – If you have multiple Collections, you must select the collection folder that you want active before selecting object(s) to ensure new triangulation object is created there – otherwise it could be created in a previous collection you might have been using and might be hidden – if is the case, you won’t see any mesh being created in view-port (it is hidden in another collection)

Examples of it working in B2.80 :




5 Likes

And, some more usage examples :





5 Likes

Hmm, i have some problems , what version off Blender do you use :? maybe i do it the wrong way ?

Hey, nice one! Really cool. Thanks for keeping this up-to-date :slight_smile:
I’ll have a closer look once I get some free time. There are probably things that could be improved in the wrapper to make it more robust.

This looks like it’s an issue with the wrapper / C-side of things. I’ve been - and still am - extremely busy over the past few months, but I’ve flagged this as something to revisit once I get through this.

Another thought: do you use Git at all? If so, feel free to make a pull request on the bpy_triangle repo so we can coordinate this. No worries if you don’t want to :wink:

Thank you, Tom – I just did some easy lifting to get it compatable with 2.80, but all thanks truely go to you for the hard work creating it in the first place.

No, I am not on Github - I am not quite there yet where I would be comfortable having a repository - maybe in a couple of years, and if I can get someone to mentor me in the true ways of coding, instead of my hack-n-peck style I struggle with now.

As Tom stated, that is on the ‘C’ side of the coding, and way above my paygrade…

However, I have experienced this in the past, but only a couple of times, and I narrowed my issue down to a single cloth pattern outline I was (re)using in B2.76 – amending it from previous B2.71 BLEND files. Once I discarded that, and started from scratch, the memory errors disappeared.

I was doing heavy testing with Triangle for cloth creation, and was going back and forth between Curve/Mesh outlines with same objects with different vertex counts. Mesh outlines technically can work with Triangle – It initially creates a mesh object from curve, and works on same mesh edge outline with all faces deleted (or an edge outline from scratch).

I have a theory that it is possible the memory issues might be related to initial vertex count, but I could be way off…

Just for troubleshooting, I am curious about your posted circles – Did you subdivide the curve segments, or are they still set at the standard 4?

This also could have nothing to do with it, and might be just an example of software only working with the right architecture/variables - It works for some, and for the unlucky ones, it doesn’t (which sucks!)

For the sake of variables – I ported this with Blender 2.80 Beta_build 480a09a92f7f-win64 (release 05-01-2019) on Windows 7 Home x64 – As you can see, it works fine on my environment, but I am curious to see if others are having success or the memory issues.

i think this is because i use windows 10 Home X64

Hi all,

I’ve tracked down some of the issues that were making Triangle not work correctly on newer Windows systems. I’ve updated the script and library on the Github page (https://github.com/tsvilans/bpy_triangle) so update it and see what happens…

Regarding Linux, I just need someone to compile the Triangle lib for Linux. On the Python side it should be setup for it already.

@Benny_G I doubt this is the issue. Try the updated version and let me know how it goes.

@DaremoK3 Try the updated version. It wasn’t anything to do with number of verts or anything like that. It had to do with the size of pointers on newer architectures and how all that is handled in the code.

Also, @DaremoK3, for your 2.8 version, you just need to replace the triangle.py and Triangle.dll files, so your adjustments can stay as they are.

After i have changed the init file with the one from DaremoK3 for Blender 2.8 and with your update for the triangle etc…

Then it works fine with blender 2.80.61:smiley::smiley:

So maybe better to update this init file for 2.79 and another one for 2.80 :smiley:

1 Like

That is awesome news – Thank you, Tom!

Yeah, I was reaching - Can’t remember the exact details, but it was the only time I had those issues when I was coding/testing with B2.76 – Your addon has always been stable for me on my Windows 7 box…

Regardless, I will update to your new files, and thank you for the update.

2 Likes

UPDATE: Linux is now supported. :fireworks:

See first post for details and Github link.

I’ve managed to compile Triangle for Linux and it seems to work OK. Download the latest mesh_triangle from the Github link. There is a new libtriangle.so in the folder as well as some small changes in triangle.py and __init__.py.

This addon isn’t appearing after installation for me. I’ve tried both installing through user prefs and manually copying the `mesh_triangle’ folder as suggested further up this thread. I’m running Blender 2.8 Beta but also tried in 2.79.

Can anyone suggest anything else worth trying?

Thanks.