Triangles in UV bake? (New problem!)

Hey, so I’m not concerned too much at the moment because it’s not the final UV layout, but while in the middle of doing the retopology for a game character, I decided to test out the normals. So I did a quick smart UV unwrap and baked tangent normals from selection to active like always, but after looking at the layout there’s some triangles in it? And it ends up in a (very) glitchy looking normal map. Although some parts look perfect?

I believe it’s either a problem with retopology, mirror modifier, or UV smart unwrap. I’m using blender 2.49b by the way, because 2.5 doesn’t have stupid retopology >:(

So anyways here’s my mesh with the normal maps, tell me if you’ve seen anything like this before? Notice how the belly button looks perfect along with the stomach?


were both of the meshes set smoth when you baked it?

Of course…

You’re right, it’s the mirror modifier. You’ll have to temporarily disable it to bake the texture.

Ah ok thanks for that. I’ll make sure to apply it whenever I do the final unwrap anyways (for asymmetry)

You’ll be hopefully seeing this finished model in the Works in Progress soon :wink:

This just cross my mind: You can display the normals by enabling “Draw Normals” at the Mesh Tools More Panel of the Editing (F9) buttons. Which is a quite handy function.

Oh sorry, when I said normals I meant the normal maps.

I got more problems now!

Check it out, model is finished, but now I’m getting a blocky normal bake? Also I’m missing the feet in the bake!?

The high poly, low poly, and lights are all in separate layers (though that shouldn’t make a difference)

No modifiers applied or shape keys, removed doubles, normals are facing correct way, normal maps disabled before bake, and everything else!

I have no clue what’s causing this?


mmm try with xnormal :slight_smile:

Nevermind, got it to work, turns out I must of had some seams selected when I extruded something, because I had random lines and face in the center of my model, causing it to render ontop of some of the UV coords and create a pixelated look.

nice news :slight_smile: