Trouble Boolean Subtracting Notches in Lamp Shade

I am just trying to do a simple boolean subtractions on a lampshade to create some notches. V2.76 I am able to do it on simple box meshes but not on my lamp shade. I created the lampshade with a spline then offset it to get thickness and then spun it to get the full lamp. Next, converted curve to object [ALT-n]. Then I created some blocks scaled and rotated to create the notches. Finally tried to apply modifier.

The technique I am trying to do is similar to this.

I have tried many combinations of these:

  • Remove Doubles
  • Have normals point outside
  • Have normals point inside
  • Remove double vertices (reports 0 removed so I think I am clean)
  • Activate Backface Culling
  • Looked for non-manifold geometry

I have been trying to figure this one out for couple days now and I just can’t get it… I am thinking either:

  • There is something non-manifold about my geometry but I have no idea how to identify where…
  • There is something I am not doing after I spin my offset spline.

I have read this this

Below is my .blend. If someone can take a look and tell me what I am doing wrong I would appreciate it. Thanks in advance.

LEDSnakeLightShade2.blend (2.4 MB)

Three gripes:

  • I wish that when it is unable to do the boolean modifier that it would give you more information about why it could not perform the modifier…
  • I wish there was an easier way to determine if the mesh is a proper manifold. Bonus points if it could also point to the potential issue preventing it. SOLVED: In EDIT mode make sure NO vertices are selected and then hit [ALT-CTL-SHIFT-M] and this should select NON-MANIFOLD vertices (if you have them).
  • I wish it were easier to detect “duplicate faces in one mesh object” as this was my problem (see below) and I was not able to see the issue at all!

Hi Stephen,

Here are the issues … and how to solve them :slight_smile:

I’ve done this in b2.79, but it should be the same in b2.76



Dude, you seriously ROCK! Thanks so much.

Couple more questions (I did try and google it out first :slightly_smiling_face:):

  • How do I detect that I have “duplicate faces in one mesh object”? I do not see them in the “scene” column on the right.
  • How do i select them to be able to move/delete them?


It was evident in the viewport:

To select these duplicate meshes, in EDIT mode, select ANY vertex/face or edge. Press CTRL-L this will expand the selection to select every face that is connected DIRECTLY to the face/edge/vertex you selected. You can them move that selection away to one side or simply delete it immediately. I repeated this until, when I tried to move the last connected set of faces, it was obvious there was no remaining duplicates.

Hope that helps.


In my viewport I did not see any on those artifacts. Maybe I have a setting that does not show this? Anyway I got it cleaned up, noches cut and exported to .stl!

Unfortunately when I tried to import the .stl into sli3er (to prepare for 3d print) it gave an error trying to import so I am on to the next problem.

Thanks a ton for your help!

1 Like