Trouble on the eye material

Hello Everybody !

I modelled an eye and I get some trouble when rendering it.
As you can see on the attached picture, there is kind of cataract trouble. There is a lot reflexion. This trouble depends on the light location but I find that the cristalline lens is not so transparent. I set the alpha down to 0.

If you could help me …

Many Thanks !


Are we supposed to guess on your object, material and texture settings or did you forget to attach your blend file to your post (including any textures packed into the blend) ?

Thanks for your reply. I forgot to attach the following files : .blend and texture.


Eye.blend (991 KB)

You have a very soft specular value so the spec that shows up across the eye, making it much harder reduces the size of the spec. Your blend doesn’t conytain the spec map so no idea what impact that would have. If you use the spec map reduce the specular value down to zero so it is only controlled by the spec map

Ooooh sorry ! I forgot the specular map too !
I set the eye specular down to 0. It doesn’t change anything.


Something I discovered a few seconds ago : rendering is OK if I remove the specular map. Why ?

I think to understand the matter : it’s important the iris not to emit light, so no specular map and material specular intensity down to 0. Am I right ?

You need to pack your image textures into the blend file if you want someone to see what you’re seeing. So far I can see a number of problems with the way you’ve set up both eye construction & materials, but without the images, it’s useless to make suggestions, since they affect the final result.

Please read my last post …

I read your post. You ask a question that cannot be answered clearly unless it’s also clear how you’re using your textures in the materials. That can’t be seen unless you include the textures by packing them in the blend file. Right now all I see is a lens material with improper transparency and specular settings, and a simple RGB material that apparently has texture modulations (color and spec) but no way to tell how that looks, because the textures aren’t available to the file for rendering.

I wouldn’t say “include the textures” if it wasn’t necessary.

I found the solution on my own. Thanks. Sorry for the disturbance