Trouble with armature+mesh then particles

I scoured the forum, finding lots and lots of threads about mesh+armature+particles but couldn’t find one dealing with this issue.

My original aim is to have a cloud of butterflies flaping its way across the screen.

First I model a simple butterflie. Add a two bones armature to it, using vertex groups, so it flaps nicely. So far no problem at all.
Then, I parent my mesh to an emiter plane using duplivert.
In my 3d preview window everything is exactly how i want it to be: lots of butterflies flie across the screen.
But when I actually render it, the (particule)wings are miles off the (particule)bodies.
The resulting animation doesn’t look like a cloud of butterflie flying across the screen AT ALL. To be honnest it doesn’t look like anything.

I tried tweaking everything i could, with no result.

Did anyone ever had the same problem?

Parent your mesh to the armature, then the armature to the duplicator?

Aligorith

That would seem to be the logical way of doing it.

However, I parented the mesh to the emitter, and with either the mesh “parented-to-the-armature” … or just using an armature-modifer they both work.

Interesting, that the armature deform and animation works on the dupliverted meshes !

Here’s a simple test file :

http://www.4shared.com/file/4634973/18a5e95c/butfly241.html

Mike

I tried parenting the armature to the emiter which seemed quite clever , yet, no changes.

I tried the simple test file you made and funny enought, in 3d view, it works perfectly, then once you anim/render, the wings go bezerk again. Actually 1 out of the 4 butterflie doesn’t behave too badly. It might the not-particule one.

Does it work well on your computer? Is it because of my blender setup? I’m stuck here.

Hmm… time to do some bug hunting.

(if any other dev looks here, it is probably something in convertblender.c)

Aligorith

I’m running WinXp.

I tested the file with both 2.42a and a CVS build of Oct-9.

What O.S. / Blender version are you running?

I’m not sure what you mean by “berserk” … if you can post either an .avi or a couple of .jpg’s of what you’re getting it might help

Mike

I run blender 2.42a under WinXP but I must admit I don’t know what CVS is.

Sorry I misspelt Bezerk, ok “crazy” is the proper word.

here’s two screen shot of what i get with your file then with mine:

http://www.nickyandkevin.pwp.blueyonder.co.uk/yours.jpghttp://www.nickyandkevin.pwp.blueyonder.co.uk/mine.jpg

It’s ok, I knew what you meant by Bezerk, just wasn’t sure what it looked like.

‘CVS’ refers to the daily builds that are compiled from bugs being fixed / new features being added. You can get a Windows build from this link (note there seems to be problem with downloading it using I.E.) (The file is the ‘win32BlenderXXXX.zip’ file)

http://www.zoo-logique.org/3D.Blender/index.php3?zoo=com

I created another file even simpler, just a cube, and I can clearly see what you mean now.

I submitted the file to the bug tracker, if you want to add your file, or keep tabs on the progress of the bug the link is here

https://projects.blender.org/tracker/index.php?func=detail&aid=5108&group_id=9&atid=125

The workaround for the moment would seem to be to duplicate the mesh+armature manually using SHIFT-D, and forego the dupliverts feature.

Mike

Ha well. Just my luck.
It’s the first time I get stuck enough with blender to join a forum to find a way out, and it would have to be a bug.
Nevermind, it’s a really cool forum anyway. I spend hours reading through it.

Thanks for helping.

I might still try to make those wings flap usings empties (I don’t have a clue how it works yet) and if that still doesn’t do, i’ll have to duplicate them.

cheers again.