Trouble with cycles rendering diffuse sphere inside glass sphere

I am trying to create an eye in cycles but the eyewhite realy looks bad the way I’m doing it.

it’s not looking glossy at all just this really grainy result.
I have a diffuse shaded sphere inside a glass shaded sphere.

Thx in advance for your help.



Eye-Test.blend (726 KB)

Sorry, no solution. I just wanted to say that I encountered the same problem and I’m still searching a way around… besides increasing the samples beyond reasonable.

(500 samples, full global illumination)

turn off caustics, mix glass material with transparent material using Is Shadow Ray as the mix factor. No need to do things the true, physical way all of the time.

Thanks! It works. However, disabling caustics must not be considered as an automatism. It clears the render even further but a lot of bouncing light is lost in the process.

Unless you’re only working on a still I would ALWAYS turn off caustics. There are ways to fake them “good enough” for animation (see my Ubershader thread), and Cycles isn’t suited to doing them in any case. I also assume that there will be a face around that eye at some point, and that the eye won’t be the main focus of the camera 99% of the time, so any light contribution of the caustics on the eye in a practical shot, especially in motion, would never be noticed anyway.