Trouble With Obstacles In Fluid Sim...

I’ve searched and searched, but found no answer. I’ve tried the tutorials on BlenderWiki and the first Fluid Sim one works fine, but when I add an obstacle (within the domain, closed mesh, designated “obstacle” in Fluid Parameters), it seems to be ignored. I’ve tried this with different kinds of obstacles, that is, cubes, planes, that nice little cup from the tutorial, and find the same problem…that is, that it is simply ignored by the fluid. Like it’s not even there.

There maybe some stupid, little thing I should be doing, or some simple, irrelevent detail I missed, but If any of you could point me in the right direction, I’d appreciate it.

And many thanks to all of those who put in there time to make the new Blender 2.4 the best ever. I appreciate every thing you’ve done…especially the fluid simulator.

did you add the obstacle after the first animation? If yes, you have two ways to deal this:

  1. get rid of all the files build during the first baking stage
  2. set the Start/End of the animation later in time than the first sim e.g. if the animation was intended from frame 1 to 250 in the first sim, then set the next one from 251 to 300 for the second one

I added the obstacle from the beginning, but something tells me you’re on the right track. Next, I’ll work from an original blend, but relocate the files to a different dir.


please also be warned that a simple palne doesn’t work as an obstacle, but a box (or an extruded plane, of course) does… I ran into this trouble myself.


Alright, I’ve played with settings and whatnot, and I still can’t get obstacles to work. Also, am having a bit of trouble with Outflow actually generating water. Perhaps there is a new or obscure tut. someone could kindly point me to? I have the feeling that there’s just a simple setting I need to tinker with.

With the obstacle problem, it seems that the water hits my little ledge, flattens out, but then goes right through it. I wish I had somewhere I could post the .Blend. Any thoughts on this would be appreciated…

Just a couple of things I’ve found in my attempts.

  1. The amount of incoming fluid seems to be controlled by the size of the inflow object. Circles don’t work, spheres work best, you can distort the sphere to control how the drops/stream form.
  2. I’ve had lots of trouble with obsticles leaking. Changing the number of verticies seems to help. One case I deleted and recreated the obsticle 4 times before I got the leakage to an acceptable level. Best to place the fluid files in their own directory and delete them before (re)baking.
  3. The size of the outflow object needs to be larger than the inflow. When I had it the same size the domain would fill up. It took making one really large (3x) before I didn’t have the liquid pooling in the domain.


Thank you much, wkv, this may exactly be the problem. I must ask, did you use more or fewer vertices to correct the leakage problem? I would assume less, as what I’m using for a rock ledge right now is pretty complex. Also, does the Inflow feature only work when you also have an Outflow object? I know it’s in early stages, but since the fluid sim is sooooo cool and pertinent to what I’ve been working on for a few years, I’m just dying to get it to work right. wkv, I think your experience can teach me alot.

Oh, and thank you, OlivS, I never would’ve known to delete the Fluid Sim files, or that planes don’t work as obstacles. You’ve both proven to have a wealth of knowledge. Anything else is much appreciated.

I just thought of this…I followed the 2nd tut in BlenderWiki, but I used subsurf and made it real. Hence, my glass had quite a few vertices. I’ve off to try it again, word for word.

The outflow doesn’t generate water at all :o . The inflow is what you’re looking for. Confusing, eh? And it doesn’t need an outflow to work; you can fill your domain till it blows and no one will care.

As for water going through surfaces, take a look at my post. In the second pic, you see that the liquid actually goes through the top of the cube, and settles just under the surface. I think low fluid resolution is the problem, but I haven’t tested it yet.

I’ve both increased and descreased the verticies and unfortunatly have not found one thing that works.

As yu_wang said you don’t need an outflow to have the inflow work.

I have also tried varying the fluid resolution, when I had it at 130 it leaked really badly, when I set it down to 120 it was much better, just a couple of drops, reseting to the defualt of 100 started leaking again. One other thing that seemed to help a lot was to switch the density from water to oil, provided that the flow still looks good for you that may work. You can find the setting by selecting “Advanced>>” on the domain. What I wanted to find was viscosity but that doesn’t seem to be implemented. Oh, don’t forget the “Set Smooth” or you end up with lumpy liquid.

Good luck. I would be interested to see your final picture when this gets worked out.

Humm…looking at yu_wang’s topic I was reminded that I had seen the same thing and reported it as a bug. So what you could do would be to place another separate obsticle on top of your ledge, make it just thick enough so that the water doesn’t leak through, after baking then move the obsticle to an unused layer, after that your render should look fine. Hopefuly you won’t have too many of these to put in place.

Well, I’ve found that the Inflow works well, but (including the obstacles) I have to move everything after baking to make it all line up. The water seems to hit in a cube pattern, but just offset from the definition of the cube. After adjusting things, it still seemed off. I wish for a tutorial of the “damn breaking” screenshots in the BlenderWiki file. Anyways, I’ve figured out the Inflow/outflow bit, but the obstacles are still not quite as defined as they should be. I’m off to try varying some settings to see what happens…wish me luck…

I have another solution for leaking liquids, in my second post. It’s really a dirty fix which will work for my scene, but I can’t say the same for others. Maybe for this case, the obstacles can be made larger than they’re supposed to be, then resized back to normal after baking. Should work pretty well.

Yeah, hi! I tried these tips too and they dont work that well for me… I wish it were tweaked a little. This is not saying that I think the fluid gen. stinks or anything, and i know i’ll never prolly be able to make it better so no one take it that way. Anyways, I will try tweaking and also does anyone know how to make a lot of fluid come out from an inflow? I’ll keep this posted with any updates I find.

Ok I found a little “tip” thing that I cant really understand… :frowning: but here it is.

Some tips: Your obstacle should have a thickness greater than the unit element of the domain (e.g., the longest side of the domain bounding box divided by the resolution) or the fluid will travel through the obstacle as if it was not there. Moreover, make sure that the normals of the obstacle are calcultated the same way, and radiating properly (use the Flip Normal button, Mesh Tools pannel, Editing context [F9]), particularly when using a spinned container. Applying the Modifier Subsurf before baking the simulation could also be a good idea.

1)I have no clue about the thickness thing does anyone know?

  1. I also heard that the fluid goes along with the mesh and NOT the shape, so Merc, the cup thing, it works well, BUT when it is a nice and pretty smooth cup it will seem to go through the cup because it is following the mesh I guess.

If anyone could explain further that would be great!

Hope this helps…

re the quantity of liquid, it appears to be based on the size of the inflow object. To get a faucet like flow I stretched a UV sphere on the z axis until I got the quantity I was looking for.

The other tip you found, “the longest side of the domain bounding box divided by the resoultion”, may be the “fix” for the leaking. I interpret the resolution to be the setting on the domain object (where you activate the bake button). I’ll pull out my model and verify that I’m respecting that constraint some time this weekend. I had already made sure that the normals were recalculated. Thanks.

Does our new boolean feature animate? If so would it not be possible to create a negative boolean that is the shape of the inner surface of your obstacle and set it up to subtract from the liquid object, in effect ‘cutting out’ any stray liquid that leaks through the obstacle mesh. I’m geussing that the way things are coded right now. (I think each frame of a liquid sim actually contains a different mesh object for the liqiud than the one previous)
I am wondering though if maybe they could code it into the next version a feature like this. Seems like a fast and dirty way to clean up any stray droplets that leak through the mesh. There could be a ‘make obstacle boolean’ button that automatically subtracts the obstacle’s volume from the liquid mesh. Viola, instant cleanup!

yeah… You lost me at boolean… I am a total noob… BUT! here we go! I have made a simple thing of what I want to do… I dont know how to upload it though…