Trying to close gaps in Freestyle lines

When I have a sphere-like object that becomes too narrow, I start seeing gaps in my Freestyle lines. Can anyone explain why this is happening?

My Freestyle settings:

I can’t quite replicate this but actually had a similar problem with metaballs last week, changing the caps to round helped a bit. Do you have a test file?

Changing the caps didn’t seem to do anything. Here’s an example file. bad (2.62 MB)

Try enabling ‘Face Smoothness’ option, and/or changing strokes to Plain instead of Sketchy.


Thanks, Paolo. Turning both of these options on helped somewhat, but now there’s a new partial gap near the top of the object:

Eh…, I would try to change the Crease Angle, or activate Contour edge type, I don’t know.


Nope, not seeing any change by altering either of those things (unless I change the Crease Angle to 180 degrees, which makes the sphere look like a QR code; even up to 179 degrees does nothing).

I have no other ideas, sorry, I hope someone else can help :slight_smile:


Hmmm, so it looks like you’ve stumbled across a bug

This is a bit of a poor solution though, I think it would def. be worth adding this blend file to a bug report

Applying the subsurface also ‘fixes’ it :frowning:

Thanks for the link. I increased the subsurface modifier to 4 and the issue went away on the deformed sphere. Now I’ll know what to do when I see this issue again.