Turbo Tools V3 - Turbo Render, Turbo Comp and Temporal Stabiliser 🚀 Cycles Renders MUCH Faster!

It’s also bounce aware. So if you render a volume for example and set bounces to 0, it’ll process the volume much faster. In the max bounces section:

Anyway, happy to hear the addon has upgraded you to a 4090 :slight_smile:

Yup, all without a big hunking GPU sitting in my PC, with a possible melting power cable, haha.

1 Like

Hi, hope you’re well.

I’ve been experimenting with new features for Turbo Tools V4 , one of which can reduce render times by a further 4 to 16x! For example if Turbo Tools is already reducing your render time by 4x, in V4 this could be further improved to 16 to 64x!!!

I’ve hit a bit of a brick wall with some missing python capabilities in Blender, so I’ve made a request on right click select which should allow me to add these additional speed ups. I’ve spoke with Ton Roosendaal who agrees it would be good for Blender’s python to have this feature, and he advised we make a bit of noise to get a developers attention.

Could you take a moment to upvote the two requests please?

Cheers
Michael

3 Likes

@Michael_Campbell
I’ve recently bought Turbo Tools, and am still doing some initial testing to get acquainted with the add-on.
The following renders have been done with the latest 3.0.6, with two 1080ti.

As you can see, I’m struggling to clean up the out of focus areas.
The other issue I’m seeing is the bottom area right under the planet being definitely darker in the Turbo Tools frames (GIF added at the bottom of this post).

Do you have any advice?

01

Turbo Render 18sec (crop)


Turbo Render 18sec Settings

02

Turbo Render 19sec (crop)


Turbo Render 19sec Settings

03

Turbo Render 28sec (crop)


Turbo Render 28sec Settings

04

Turbo Render 3min 17sec (crop)


Turbo Render 3min 17sec Settings

05

Open Image Denoise, Noise threshold 0.05, Max Samples 4096, 3min 58sec

06

Denoise off, Noise threshold off, Max Samples 2048, 11min 11sec

TurboTools-issues

Hi, you need to disable ‘prevent fireflies’ if it’s too dark. That option basically reduces the clamping values to direct 4 indirect 10.

The noise is caused by:

  1. image 1. didn’t have heavy dof/motion blur enabled.

  2. image 2. can’t see noise

  3. image 3. appears to be a volume but the volume options are not enabled. I’d also recommend to disable shadows and diffuse for the volume object in the object properties:
    image

  4. image 4. The scene is too contrasty for the Cycles adaptive sampling algorythm. This is a known Cycles bug, where cycles introduces noise patterns that are so distinct that they appear intentional to the AI denoisers. Definite solution, switch to ‘User’ sample preset, and disable adaptive sampling by unchecking ‘noise threshold’ and entering your own samples/time limit. Possible solution, turn on the ‘interior’ option, this basically increases min samples which may help.

  5. image 5. Same as image 4 (cycles adaptive sampling patterns)

ps, for really noisy scenes like this one I’d always recommend to turn on the interior option for increased min samples :+1:

Also, if you have any emission turned on in the volume material, then you should also tick the emission option.

1 Like

Great!
That really helped, @Michael_Campbell

New render, 6 min and 8sec at 1024 samples, which is half samples of the regular Blender render (the image 06 I posted above).

Settings

I didn’t turn on volume, as I’m not using any. The bright area behind the planet is just an HDRI map, if that’s what you were referring to.

1 Like

Excellent, glad it helped.

Are you sure there isn’t a volume atmosphere around the planet? I can’t think of any other reason how there could be volume esque pixel patterns in the empty surrounding areas:

image

They seem to be too far away from the planet to be part of it.

Oh! You meant that volume. Yes, you’re right, I totally forgot about it.
So, checking the volume option on could speed up the render a little more?
Oh well, I’ll try, though already quite pleased with the improvement!

1 Like

quickest way to check is in the viewport by swapping to volume direct/indirect:

1 Like

yes the volume material.

In your case i’d try:

Also tick the occludes transmission option if there is any transmission visible through the volume.

By the way, unless you need to use the individually denoised passes in post, then you should use ‘high’ denoise mode rather than ultra. It’ll then denoise much faster, and potentially allow you to use fewer samples.

1 Like

you may be able to lower the samples all the way down to 32 or even 16 once you enable the volume options. Although if you go too low with the samples you may reduce glossy strength in some areas, so just trial and error. The lower the faster obviously.

I usually find the optimal samples by rendering a small render region that covers the noisiest part of the render. Ensure you turn on crop to render region too when doing this, it makes sure only the rendered pixels get denoised rather than the empty pixels:

image

1 Like

I’ll try that right away.

In the meantime, an update on the volume. Turning off the shadow it’s not ideal in this case, it affects the look too much:

TurboTools-rayvisibility

That’s wierd, turning off the shadows on the volume should let more light through, in your case it seems to be letting less light though. Perhaps you have emission on the volume material. If so, you should also tick the emission option and the emission behind volume option as well. But you could still turn off the shadows option, but leave the diffuse option ticked so the volume emission still illuminates the planet geometry.

Or I suppose it could be a case of the volume scattering redirecting the blue light in to the planet instead of grazing it.

Hm… the volume shader is pretty basic
image

By the way, I just tried with the other settings you suggested, and this time I turned the max samples down to 256.

I can see some degradation in the bokeh compared to the 1024 samples, but I went from the initial 11 minutes grainy image to 1 minute and 47 seconds!

Very curious to see what will happen with the new build I’m putting together, with a dual 3080ti.

Thanks for the suggestions, @Michael_Campbell this is working great!

1 Like

Awesome, glad it’s working well for you :+1:

Nearly 7x faster render isn’t too shabby :slight_smile: 512 should get you an even better result whilst still achieving a 3-5x reduction in render time.

Thanks for the purchase by the way :+1:

1 Like