Two Textures with two different UV maps not displaying properly...

I have a building that I am trying to texture for work and at the moment I am working on the parking lot outside. I have made the asphalt texture and it is a seamless texture with its own UV map and the unwrapped mesh is scaled up pretty big. On the other hand I have a second texture that is the parking lines and wheelchair “painted” on the asphalt and it has its own UV map as well. This UV map is smaller. It looks great in GLSL but when I push “P” to play the game, it switches around and the Lines and wheelchair are tiny and repeated as if they are following the wrong UV map.

I have made sure they are both set to the correct UV map in the textures “mapping” panel.

What can I do?

Here are some images…


Sounds like you may have ‘face textures’ enabled in the materials panel. Try disabling it.
(it seems to overwrite the first texture in the list with whatever image the currently selected UV map is displaying.

If that isn’t the case, check that the mapping of the UV is set to scale 1.

Thanks for the reply sdfgeoff, I checked both of those settings and they are both set to the correct setting.

While working on other stuff in the same scene I found that it is working on other models but not this particular one. It is kind of buggy too. Sometimes it works on the model and sometimes it doesn’t.

Are you using node materials, by chance? Have you tried different versions of Blender?

I’m not using node materials. And I haven’t tried a different version of Blender… I will try another version and see what happens.

Thanks SolarLune!

I don’t know why but without doing anything, it is working now. I have no idea what happened. Thank you everyone for your help!