u3 smartdrive?

can someone figure out how to put blender on a u3 smartdrive. I think you have to use the software package factory to do something to the .exe.

i tried making the .exe into a .u3p which is what you use to install apps on the launchpad. When I put the whole program on and include the .u3p it comes up with the black box command thing but then closes within a milisecond. Like just flashes.

Vincimus, the .u3p file isn’t an .exe file, but it’s actually a zip file fwith a different extension. If you rename it, you can then open it up with pretty much any zip program. I’ve got a couple of them here, I’ll just see what the format is again. From memory, it’s a zip file that contains a couple of xml files that tell the U3 what and how to run the package. Just a sec, I’ll have a look

Yeah, the app is in the ‘device’ folder and the xml file I mentioned is in the Manifest folder, named Manifest.u3i.

I wondered about doing this sort of thing to apps a while ago, but instead just installed it onto the drive and then browsed to the correct folder. BUT, that was until I discovered PortableApps.com - it’s another menu suite like U3, except it can have any app added to it’s menu. You just have to install the app to a folder inside the folder PortableApps, and that’s it - easy peasy.

You can even have both menus ion the one drive if it suits you.
Have fun…

riiiiiiiight okay well my question wasn’t about portable apps which i downloaded and found that it sucked but my question was how do you put blender on u3 launchpad?

Yeah, no kidding. My eyes work just fine thank-you vincimus.

Well, if you’d actually bothered to have a look in the files and have a bit of a play, you’d have worked it out already for yourself. Anyhoo, no matter - I’ve wondered how to do this myself for quite a while now.

Download this Zip file, unpack it into a new directory, copy all the files in your Blender directory into the ‘Host’ directory, then compress the 4 folders (Data, device, host, Manifest) into a zip file. Rename that zip file Blender.u3p.

Open up your launchpad, click Add programs, then just pick add from your computer and browse to the file


Let me know if it won’t work for you.


Eh hem sorry if I was rude I guess I was just mad at the fact that I thought I couldn’t remove Portable Apps. Anyways it isn’t working i downloaded the .zip and then opened on my desktop imported all the files in blenderfoundation/blender/everything in here and moved it to host I then used 7zip to put into a zip file and then renamed it blender.u3p and also tried blender.u3p. When i try to select it it doesn’t appear. Sorry excuse grammare I am writing via psp because laptop isn’t connected to internet right now

Oops! Me too. Sorry I grumped at you mate.

Hmm, no worky huh? Well, then I’ll just throw the copy I made up onto savefile.com somewhere.

It’s 8.3mb (no python or Game Engine), and was built on the 29th of Nov.:eyebrowlift:
But you can always open up the ‘u3p’ file and add the game engine .exe file into the package.

Just in case it’s worth mentioning, I just grabbed the WinRar for U3 package and chopped and changed it until it worked. The least fun part was working out the name of the directory that it gets copied into (some huge-ass long hexadecimal number), so I just copied the WinRar one and added 1 to the last digit.:wink:

I’ll be somewhere I can upload it in about another 2 hours or so.

thats fine ty

Here you are Vincimus, hope this one will fire for you. It’s the SVN I got from graphicall earlier this morning. There’s no sound and yafray crashes. Still, have a play with it and improve it some.


I know this is an old thread but I was wondering whether some of you managed to run blender 2.47 on u3. I still don’t get it how to make it work so I still use the 2.45-version that enhzflep made, which btw is awesome!

So if anybody can give me an explanation or make such a file, I’d be him/her very grateful.