Ubuntu & CUDA... Again Blender, seriously?!

Hey guys!

I’m new to Ubuntu, and it took me a long time, quite a few failed attempts (and help from a friend) to get Blender to ‘see’ my CUDA GPU…

But then I opened my preferences today to set up a new starup file, and noticed that ‘GPU Compute’ had disappeared from my ‘Compute Device’ options… :mad:

The thing I don’t get, is that I haven’t even opened Blender since the moment we checked (with my computer wiz friend) that it did actually show when we installed Ubuntu… Haven’t touched a single thing!

The only thing that might be different, is that my computer automatically updated Blender to 2.75a

Now, I’m only a hobbyist, so it’s not like it’s professionally vital that it works… But GPU renders are sooooooo much faster, that I’m here asking you guys for help… :cool:

Any ideas please?..


PS: I’m on Ubuntu 15.04/64bits, my GPU is a GeForce GT 740M…

When said ‘a few failed attempts’ earlier, I was talking about the fact that NVIDIA drivers alone are not enough… It took us some time to figure out that we had to install the CUDA toolkit as well…

Shouldn’t be necessary. Nvidia drivers from repo come with cuda runtime that official Blender can use. Building Blender does require cuda toolkit, as does repository versions of Blender.

Multiple people have reported that cuda is not available until Blender is run as root. That suggests a permission problem in Ubuntu, with nvidia drivers, or both but I don’t know the cause.

@JA12 unfortunately is not possible to compile the CUDA kernel only installing the nvidia driver in Ubuntu:
I remember trying installing some packages that supposed were CUDA runtime, but I could not do it. So the best way is using official Blender that contains the precompiled CUDA Kernel and no need install CUDA toolkit.

@Nunud, install “nvidia-modprobe” package from software manager. Reboot the system.
Download official Blender 2.75a for linux 64 bits (tar.bz2 file):

Open the file browser, extract the tar.bz2 file to a new folder, enter to that folder and execute (double click I guess) the “blender” file. See if you can find the CUDA option in User Preferences in the official Blender.

For Blender to be updated automatically, you must have installed from a ppa (the version installed from the vivid repo is 2.72).

This one doesn’t seem to include the Cuda ‘lib’ folder required to run Cycles on GPU. You may have to add it from the official download.

It is always recommended to use the official builds unless you know what you are doing. PPAs are never recommended, and are not officially supported by Canonical. It is a Personal Package Archive, just about anyone can offer software for download.

That’s pretty much exactly what I said. If nvidia-modprobe helps that’s great but on Mint that didn’t change anything, wasn’t even in the repo anymore. Suspecting something else is going on.

I did the recommended blacklisting of noveau driver in Mint, and that was all. Must admit i installed also the cuda toolkit for my development.
After lot of probss with fglrx from amd earlier, i was astonished how ootb the nvida driver installation was.
No probs to see cuda in blender.



Thanks for all your answers, and sorry I couldn’t get back to you guys sooner…

I must confess, I was rather intimidated by how technical some of your answers were… I come from a Macintosh background, and I chose Ubuntu because everyone told me it’s the easiest distro to run… :eyebrowlift:

So right now, I just installed that “nvidia-modprobe” thingy, and downloaded the lastest version of Blender from the official website… I’ll get back to you when I try to actually install it… I’ve never installed apps that didn’t come diretly from the Software Center… Maybe I shouldn’t post a reply before doing it, but I didn’t want to delay my answer too long…

@organic: I did install that PPA, because I didn’t know how to properly update an app on my own, but it seemed like a reputable source at that time… Maybe I was wrong…

Thank you guys again, And I’ll keep you informed of my progress!

I really don’t get it… CUDA is back… All I did was install “nvidia-modprobe”… I haven’t even replaced my version of Blender with the official one yet… But it does work now… Thanks @Yafu!

Thank you guys for your help! :cool:

I’ve never seen a ppa that wasn’t reputable, but because anyone can create one a note of caution is advised, especially if you don’t know how to investigate any issues that come up.

Glad you got it working :slight_smile: