Unable to render AOVs

Hi there!
I’ve been trying to render a AOV pass, but even in a clean scene I do not get any results. All the channels remain simply black.
Here two screenshots of my simple setup. The char has an AOV output to the very descriptive name ‘olda’, but when rendering the pass there is nothing visible.

Do you have any idea what could be the issue?

Could you double check your AOV pass name and your AOV Output node Name value? Either retype it to what you want it to be or check for leading or trailing spaces. If there is a difference between the two names, you won’t get an output.

That is not the issue, I renamed it already couple of times today and just tried again. Still doesn’t work :confused:

Ok, I’ve found the issue.
I’ve opened again a new scene and found it was actually rendering the AOVs suddenly. Then I compared all my settings with my scene and found the issue:

AOVs do not render when Open Shading Language is activated!

Of course, this is very unfortunate as this is the reason why I wanted to use AOVs in the first place, but thats how it is.