Unable to Zoom or Pan at a Legit Speed.

I gotta MacBook Air, and everything was perfect when I got Blender yesterday, but now there is a problem. I’ve even tried reinstalling Blender, but whenever I try zooming, it goes very, very slow. I have an external mouse, with a wheel, and the scroll speed is set to max. Also, when I try panning around (holding down the scroll wheel (3rd Mouse Button) and Shift and moving the mouse around) it does the same thing. Really annoying an unusable.

Thanks in advance.

How zoomed in are you? Usually when you’re very close to the center of view and try moving the view around, it goes really slow. Try pressing the period key on the numpad (if macbooks have one, otherwise press space and search for “view selected” and hit that. If that doesn’t work I’d try resetting it to factory settings under file(top left) and selecting “Load Factory Settings”.
Hope this helps :slight_smile: