Unknown CUDA error (cycles viewport rendering)

Intel core i7
Win 7 pro
Zotac GTX 460
ATI Radeon HD 5750
Blender 2.62 (and 2.63 testbuild2)

I use the ATI for my monitor and the GTX for Blender/Cycles. And it has been working fine, until now…

When switch to cycles viewport rendering I get this error message, and when I try to change back, Blender crashes - every time.

This problem came from nowhere for me, and I don´t know what has changed on my system to cause this. :confused:

When I change to using the GTX connected to the monitor though - all is fine and dandy (as Jonathan would have put it).

In an effort to solve it I also updated the Nvidia Drivers. No luck there…

Could it be a Microsoft update that has changed the game?

Any clues?

And… F12 rendering is also working as normal.


Have you tried what I suggested at the end of my thread? Right click on blender icon (or shortcut) and then select “Run with graphics processor” then select your Nvidia GTX from the pop out menu. I am sure this issue is related to having a dual card setup. I have raised an issue on the bug tracker but this should work as a workround for now.


No, because I can´t find that option anywhere no matter how hard I look. It´s not where you describe it, and not anywhere in the options for properties.

Thanks for helping out.

This is what I get. Not sure why you don’t have the same option.


Interesting, but I don´t have it. Although I don´t have the desktop icon, but checked the taskbar icon and the actual program icon. Shouldn´t make a difference.

I´ll see if I can figure that out. Thanks anyway!

Seems to be a setting in the Nvidia Control Panel. Time to switch my monitor to the GTX card again!


Researching that did not help me, unfortunately. Hope this affects more than me (well, not really…) and is considered a bug and gets addressed in a future Blender version.