Unrecoverable error in SubSUrf calculation


Unrecoverable error in SubSurf calculation, mesh is inconsistent.

anybody ever experienced this error message? I only saw it with 2.49 and in conjunction with Yafaray. But I get the suspicion that Blender 2.49 has a bug here.

The objects make the exporter crash. Only remodeling will hepl. Assigning new materials etc will not.


looks like a known problem - check this one out:
Blender corrupted the mesh completely and turned parts into - non-manifolds.

No dev knows about this? recently on a daily basis my files are getting corrupted …

Can’t really help without more information. Telling us how to reproduce it is an important part of a bug report.

It happened to me two or three times recently, but I haven’t seen it for a couple of weeks and I have no useful information on what might have caused it. It was much, much worse than the posted example though.

I often use a recent svn build, so maybe it is fixed now ?

This now happens to me with EVERY blender file and makes either Yafaray or Blender unusable
because I cannot afford to repair each scene on a regular basis.

This seriously makes this software unusable.

Can you tell us how to replicate the bug on our machines?

looks like you got a non-manifold object there, like one of those impossible torus objects, turned inside out. I can see the edges that are an issue, simply delete them and face the outside like a “real” object.

I’d hate to sound patronising especially because you’ve been around longer then I have but I think you should just file a bug report.

In the meanwhile, can you try this on another system?

work with Blender 2.49 and Yafaray current build and it will happen with EACH file you work on. I just fixed one file - worked a little and bang - again a different mesh is now corrupt.

I submitted it as a bug as well.

now I also get this issue:
8/26/09 3:07:34 PM com.apple.launchd[581] ([0x0-0xd80d8].org.blenderfoundation.blender[2256]) Exited abnormally: Bus error
8/26/09 3:07:34 PM com.apple.launchd[581] ([0x0-0xd80d8].org.blenderfoundation.blender[2256]) Exited abnormally: Bus error

I will switch to win for a moment and see if the same happens there.

Probably a stupid question but why 2.49 and not 2.49a and 0.1 and not 0.1.1?

Your bug report scene crashed because of some images that failed to load, no error about geometry here (2.49a 0.1.1 on windows).

sorry the numbers yo mentioned are those I also have
2.49a and 0.1.1 for yafaray.

the texture problem is true but this happens only when the mesh is corrupt.
I can render in clay mode with yafaray without a crash.

When you open Blender it tells you that there is a subsurf problem.
You did not get this error message under Win?

There are enough cases of corrupt meshes causing crashes. The problem is we cant make every blender tool/modifier support incorrect data (would slow down blender too much).

We need to know the steps you took to make the corrupt mesh in the first place.

This time I got the message, your towels exploded… and when trying to edit them blender crashed. The parfume bottle that was corrupted in one of your images was totaly fine and editable…

what do I do?

I model with polys and also use the subsurface modifier. That is all.

That is basically all. Also a simple box with had modeled beveled edges
got corrupt, but objects with the subsurf modifier are more prone to get messed up.
And with messed up I mean real messed up. Not only some edges were added, but the
mesh looked like a fractal explosion.

I will try to work on windows to see if the same issue happens here and try to avoid
the subsurf as well to see if that is the main reason that causes it.

Subsurf can be backed before going to Yafaray when the exporter together with Blender
make the mesh corrupt.


that is what I mean it is random with objects. And I cannot repeat it with the same object.

What are you system specks? Do you also have yafaray?

bus error…I wouldn’t rule out a bad memory chip in your PC…

I’m running on a P4 630, 2Gb DDR2 of memory and a 8800GT graphics card.

I have Yafaray but I can’t say I have used it together with subsurfed meshes since 2.49a with 0.1.1.

I tried appending the exploded towels in a new file, they were still exploded. I also redownloaded the file and tried to append, the towels where still all over the place. So it’s not a problem whilst reading the file. So blender for some reason indeed corrupted the file.

Faulty hardware gave me a hard time with blender to a couple of years ago.

PapaSmurf :
that would mean that snelleeddy also has a bad memory chip.

the bug is only triggered when you use yafaray if I understand correctly? If you model and never ever render with yafray then it is ok no? Can you explicitely describe the operations leading to the bug, is it like this:
-create a new object and save it in a blend file. : OK
-reopen that blend file : OK
-add a subsurf modifier on that object, edit it and save : OK
-reopen, render (internal), edit, render (internal), save : OK
-reopen, render (Yafaray), edit, render (Yafaray), save : OK or NOT OK ?
-reopen : corrupt
-edit : crash

Can you tell us at which step in the above workflow things start to go wrong?

-can you reproduce the bug on your own objects?
-or only on files from cekuhnen ?


Papasmurf’s idea can be correct and doesn’t imply that my ram is faulty, as I wrote, when appending an object out of a freshly downloaded scene from Claas there is already a problem, so the problem is in the file, baked into from Claas’ computer.

I just fooled around a bit with a subsurfed scene and it seems to work (subsurf+yafaray+saving and opening and such).