? Unwanted Glowing Edge ? (Image Texture with Single Level Alpha Problem)

I keep getting “glowing” edges in an image based texture which should not be there. Image used has single level alpha transparency. The background is 100% transparent and the image is 100% opaque. No blending or partially transparent areas.

How do I get rid of this false glow? Why is it happening?

Attachment 1: Render showing odd glowing edge.
Attachment 2: Screen shot of Blender showing:

  • 3D view.
  • Material panel showing I am using Z Transparency so the alpha channel should be used (and in fact is working except for the glowing edge around the 100% opaque area of the image.
  • Texture panel showing I do have “Alpha: Use” checked.

Attachment 3: Screen shot from Photoshop where I opened the exact same file then added a black background layer behind the lotus flower image as the only change. Note there is no “glowing edge”. No other program except blender shows this weird glowing edge.

What am I doing wrong? How do I fix it?

Blender 2.64
Blender Render


I have not had an answer or suggestions to this yet. Would it be better posted in another forum? It appears to be both a texture/material problem and a rendering problem. I do not want to cross post but would it be better if I posted under rendering?

Try the Premultiply setting (checkbox) at bottom of the image panel.


I concur, this for sure is the result of not clicking the premultiply checkbox. :slight_smile:

Thank you. Yes it was the premultiply not being set.