Unwrapping dimension problem

Hi. I first want to offer an apology because this is my first post and I’m not sure that is this right place to post this kind of problem.

I got this character model and I can unwrap anything else but hands right. It’s like unwrapped from wrong dimension. Normally unwrap-option just “open” the model you know? Now its still closed and just 2D-image of it or something.

Here’s picture what i mean.
This is what I have been doing.

This is what it looks when unwrapped:

And finally it’s look like this if you zoom to middle:

So its like it has not been unwrapped but just like taken screenshot in wireframe mode? My model other objects dont do that when unwrapping. Thank you.

Sincerely Yours,
Ilkka Peltola

I can only see one seam around the wrist, that would not be sufficient to flatten out a mesh of a hand.
Say you have a glove, how would you flatten that out without massive stretching unless you cut along its seams ? That’s what in effect you are doing when UV unwrapping

Thank you for quick answer. I’ve tried several seams around it. Maybe i’ll give it one more try. I marked seams like in gloves, but maybe I did it still wrong.

BTW, sorry, I posted new thread with same topic, would you delete it?

I tried new seams positions and ITS WORKING! Thank you. Very good first time with you guys!