[updated july 19 2019] Eevee real object based Motion Blur v0.4.3

Welcome to the community!
I don’t know what may be happening here. Maybe if you send me the file somehow I may guess what’s happening.
Thank you!

I press render motion blur, and nothing seems to happen. Im preeetttty sure I’m doing something wrong. Just wondering what. Thanks for creating this and helping with problems

Keep in mind that as it is right now, this is more of a scripted workaround than a real addon, so the rendered frames go to the output folder as image sequences, and not to the preview window. Check there. Also, I couldn’t make the addon update the status bar or anything with some progress, so Blender just seems to freeze while the script is running. I hope to solve both issues somehow… Any ideas are welcome :slight_smile:
Let me know if you could make it work!

I found a single frame rendered from the add-on, but it didn’t have motion blur.Also is there any blueprint for when motion blur will be added to eevee?

Hey Pablo! Great to read your post. I am glad you did used Mirai model back then. Hope your project continues to grow. Cheers!

2 Likes

If you can upload the project here I can open it and see what’s happening

I don’t know… Check in Right Click Select.

This looks great and will solve some things for me in the short term, so thank you very much. Reading through the thread I wondered whether the gamma issue might be something to do with the colourspace of .exr being linear, if your process is still converting from .exr Bear in mind I really don’t know what I’m talking about :wink: Just a thought that I thought might trigger a helpful thought.

@g3ntile run a laptop- i7 6700HQ, nvidia 980m- and im really sure that its a beast of its time. but when i run the commands to render motion blur- blender freezes and it never recovers. does anyone else face this issue? Im running the latest 2.81.

It’s a known limitation that it appears to freeze, but is actually rendering in the background. I had the same apparent “problem” when I first tried it. To test, try low samples (turn off adaptive sampling) and hit render frame. You should see your result after not too long. More complex scenes still take a while to render, unfortunately, because it has to render the scene multiple times.

1 Like

The highlights are clamped in the EXRs I get from the motion blur renders when compared to the regular F12 renders. Is there a way to get around this? Thanks!

@g3ntile I noticed an issue while rendering with the add-on. There is sever banding in the darker areas of my scenes, when using volumetrics.
The add-on seems to be having trouble with gradients from subtle light changes in volumetric, and adds harsh steps to the subtle change in color and luminosity across the volume.

I’ve tested using several samples and with just one. Even one sample where nothing has to be composited, the banding still shows up. The same scene rendered with F12 will render the image fine.

It looks a lot like compression banding or low bit dept banding in video. I’m only guessing but I think one of the two if not both, from below, is happening.

  1. Possibly defaulting out of Filmic?
  2. Possibly defaulting into an 8bit color space?

Thanks,
Tim

I’ve noticed this too. This motion blur composition hack seems to clip the highlights pretty bad.
In my above post I’m theorizing that the add-on maybe defaulting out of the “Filmic” color space.

I hope this can be solved.
If the developer just made this quickly for a project then abandoned it, then I hope another developer could take a look.

@g3ntile I read through some of your post here, and I see that you were having trouble matching color spaces i.e. “filmic”. For now I don’t really need the latitude/dynamic range of filmic but I do need less compression of my files.

I wanted the output with Open EXR but the add-on compresses the files 100% compared to a regular F12 EXR.

Your notes above about setting the compression to 0 in the render panel works for PNG’s but even at 0% PNG’s are to compressed vs a no compressed EXR file. And Exr’s don’t have a compression option in the render panel.

My question is: Is there a way for me to force Open EXR at 0% compression whlie using you add-on?

Thanks,
Tim