Using bMesh file in 2.5 A0?

I wanted to use a head modelling tutorial I found, and it uses n-gons as an interim phase before converting everything into quads and a few tris. But, since the current alpha doesn’t do n-gons, I decided to try using b mesh, and then move things over once the file is all quads and tris.

Oh, what a fool am I. </dramatic>

Anyways, I open it up in 2.5 alpha 0, and lo and behold… it didn’t work. :ba: All I had were lines stretching to infinity. (They were probably edges, but I didn’t check and it doesn’t matter anyways.)

Okay, so I thought, well, maybe I’ll try exporting the file as an .obj or a .3ds and then import it in 2.5. Well, b mesh doesn’t export. It just crashes.

Anyways, to the point: Anyone know how to get file saved in bmesh into 2.5? Backdoors? Tricks? Ideas? Anything?


Does bMesh have an option for triangulating. If so you could use that and export .obj.
Optionally, in Wings, use Faces->Tesseleate->Quadrangulate. Import back in Blender regular.

Or post the file here :slight_smile:

Well, that’s the issue. It won’t export. Bmesh can’t export because it’s only testing the modelling features.

Triangulating might work, but it’ll be a pain in the ass to put all the tris back into quads when I’m done. I’m not sure if bmesh will do it anyways, i’ll have to check.

Can you post part of the file here?

Yeah, i’ll attach the .blend.

Also, if you don’t have bmesh, here’s the download link: I’m pretty sure it won’t open in anything else. I’ve tried all the blender builds I have: 2.50, some SVN build, the one with Collada (now obsolete though).

Just thinking out loud, does anyone know if there’s another build with bMesh that’s a little more… capable? If not, I don’t think they’re planing to release another build until 2.52 or 2.53.

What about a program that can import .blends? Does that exist?

Okay, I don’t think the .blend will work. It’s saving another file named head1.blend1 which appears to be where the n-gon object is saved. The .blend only has two spheres for the eyes, which never had n-gons to begin with.

I’ll upload the .blend anyways, but the system won’t let me upload the .blend1 file.


Head1.blend (123 KB)

As far as I can make out, the problem has something to do with either the Mirror Modifier or the SubsurfUV Modifier, probably the latter.
found bundled python: D:\blender\1_BLEN~1\BMESH_~1\BMESH_~1.blender\py
RNA_boolean_set: VIEW3D_OT_select_lasso.deselect not found.
RNA_boolean_set: VIEW3D_OT_select_lasso.deselect not found.
error: this CustomDataLayer must not be written to file
error: this CustomDataLayer must not be written to file
error: this CustomDataLayer must not be written to file
subsurf conversion time: 0.059295

I removed these, saved as Head2.Blend, and it opens in B2.5a0. File is attached. fwiw, I’d suggest you use the latest 2.5 build from Graphicall, or jms’s site (

You can re-apply the modifiers in 2.50, once it’s opened

Good luck :slight_smile:

Well, there’s progress anyways. It <i>does</i> open in the 2.5 alpha 0 build, and I can see the shape and everything, but it crashes as soon as I try to get into edit mode.

I just downloaded a few builds from graphicall and one from the zoo blender site you sent (though I can’t speak french) so I’ll see if any of those give me some progress.

I’m not too sure which of the builds I should have downloaded, I downloaded the latest SVN and one other one, but there’s so many builds I don’t know which are worth their harddrive space. :S

Thanks for the help.

You’re right: I get this message on the console, just before crashing:
error: this CustomDataLayer must not be written to file.
I also tried exporting .obj and re-importing. Seems to work, butthe geometry seems a bit corrupted. I’ll try again later, but I’d suggest you report this on the blendermesh site. Or on jestkerking’s blog.

I forgot to mention: If you’re downloading from jmsolier’s site (zoo-logique) you’ll should download and instal the first.This forms the base.
Then, when installing the latest 2.50 pack, just replace the corresponding files with the contents of the zip.

In graphicall I’m not too sure: Perhaps jesterking’s.

Good luck


You are using a old build.

Head over to :

Download the win32_Bmesh25_100113 SVN Rév : 25962, version and also the win32_B25_100115 [ordinary Blender 2.5 build - you will need it]

If you don’t have it grab also :

Unzip first

Copy Bmesh into that directry and unzip. [running bmesh now produces a window with no buttons visible just the 3d scene - bummer, but there is a solution!!!]

Finally copy Win32_B25 file into the directory - unzip, start Bmesh and now everything is fine.

Happy Blending campers…


Okay, I installed that build which is much nicer than what I was using. I might be able to make due with that for now. I still haven’t tried exporting with that build, I’ll let you know how that goes. Thanks.