Using normal maps in Unity (tiled) ?

Hello everyone!

Today I ran into a problem while trying to use a scene from Blender in Unity.
I used a texture atlas and unwrapped some tiles.
Afterwards, I built a scene out of them.

When I load the scene in Unity, the mesh itself and the diffuse map are fine,
but when I use the build-in Bumped Diffuse shader and a normal map I created,
Unity will show me a checker-like error.

Here are some images:
Using only the diffuse map:

Using diffuse map and normal map:

Some more information, if required:
I am using Blender 2.71 and Unity 4.50f6.
Also, I use the .blend file in Unity directly.

Does anyone have any ideas how I could solve this?

I should also note that I unwrapped one original tile per sub-texture and mirrored that tile so that it seamlessly connects to the other tiles of the same sub-texture. Afterwards, I mirrored those tiles, too, in order to get 4 tiles that can be placed in the whole scene seamlessly.
After I thought this could have caused the problem, I tried not mirroring the tiles, but the uv unwrap instead which led to a similar look.
I also checked the normals. They seem to be fine. I use backface culling in Blender and Unity uses backface culling anyway. There are no holes in the mesh that aren’t supposed to be there.

Many thanks in advance,

Did you set the image up properly when you imported it (slightly different settings for normal map and bump map, btw)? If you use a diffuse texture as a normal map it sometimes looks like that. Also your normal map doesn’t look much like a normal map, it looks more like the blue channel from a regular image, I don’t know if that’s intentional or not.

Thank you very much for your answer, KnightsFan!
You are right! The “normal map” I used wasn’t generated correctly.
I thought Unity converts BW-bumpmaps to normal maps when I just throw bump maps into the normal map input.
Apparently, I have to set the bump map’s texture type to “Normal map”, which created a working normal map.
The scene looks like this now:

I guess I still have to get rid of those mipmaps, though:

At least I’ve read about lines appearing when mipmaps are being used.
Also, this does seem to make sense, because the lines will only appear when the polygons are further away.
As far as I understand this correctly, mipmapping won’t make sense here because I use a texture atlas and tiling anyway.