Using Relations to Hide Layer in Animation Problem

I have an Animation that does not work any longer since 2.65, it worked in 2.63, don’t remember it not working in 2.64, but I have not had to change the file till recently, here are the Steps I used to create the problem:

  1. Duplicate the cube in a default session (Shift-D), move it to one side (y 5), so you can see both cubes and move it to the Layer next to the default layer view (M 2).
  2. Make sure you are at Position 1, under Object tab -> Relations, with Duplicate Cube selected, the selected cell should be the one we moved it to, so just place cursor over Relations -> Layers interface and hit i to insert keyframe.
  3. Now move position to 30 and change Relation Layer to default cell (the one left of it or top left), then add keyframe.

Now the Duplicate cube should now be seen, so you see two cubes, now hit the rewind to beginning button (go to position 1) and note that the Relations window is Yellow, meaning it has a keyframe, but both the default cell (or cell we selected to be the view layer) and the original layer are selected, and the cube is still in view, even though we set it to be off in set 2, now move to position 2, note that the Relations window is now green, and the original layer is selected, so you would think that the cube would be invisible but its not, now moving positions from 1 to 31 you will note that the visible layers shows the selected object moving from original cell to the default view cell, but cube is still visible, now click on the visible layer cell for the lower second cell that we moved the duplicate cube to, and we note that it moved to the default view and stayed there.

  1. Move to position 40, select the original cell under original and insert keyframe, note that the cube disappears, but moving from position 1-50 does not bring the layer back.

This looks like something is broken, a bug, what do you think?

I ask because I don’t know if they changed the behavior of Relations, but I know it did work this way once.

Edit: I run Arch Linux, normally the repo is cutting edge, but today it wasn’t, so I downloaded and I tested this in 2.66, you can not insert keyframe, so I take it this behavior is changing or they know its broke and disabled it, I verified it works in 2.64a.

Found it was removed, bummer.