UV atlas wont save uvs to objects

I am using texture atlas to manage multiple objects uv maps but as soon as I have finished manual unwrapping uvs go to their original places as if they werent edited at all. Any help? I tried with another model and the same problem persists, is uv atlas broken or what?

I ran into the same issue once in a while and it seemed to occure randomly, sometimes it worked out fine, somtimes it didn not. Then I found out, that it only happened if I changed the geometry whithin the TextureAtlas merged object. You must not edit, add or delete any faces within the merged object. Changing any geometry should only to be done in the several separate object.


i have the same problem, just wanted to post a thread about it… I have 11 Objects, pre-uv mapped, then I want to join them in an atlas. But one of the object refuses to save it’s new UV-coordinates at all, when I click “finish unwrapping”, the uv-coordinates of that particular object jump back to the original position :frowning: But like Influenzo said, it might be related to making (even minor) changes to geometry, because I did that.

However, there is a small workaround that seems to work.

Before quitting the UV-Atlas, select the faces of the malfunctioning object. Copy them, then seperate the new object with “p”. It creates you the single object, but the coordinates are still where you set them in the atlas. Try it, maybe it can be a solution for you.