UV packing

Via installer and yeah that’s where I’ve uninstalled it from :slight_smile: also used Everything to actually delete any file or folder with the shotpacker name from my entire PC

That is very Bizarre…never seen that happen on any add-on…
I will keep thinking and see if anything else comes to mind…

That is beyond strange. The only other thing I can think of is some sort of locked process / file so even a re-start means it won’t work as it’s still locked. Though I have zero idea how you would check that.
Daft question, have you tried it on a different version of Blender? If you have multiple Blender versions on your system, back up your config, add the addon to that version and see if it works.
Dunno if this may be of use?

Try pressing the “update stats” button in the Shotpacker Stats panel. It resets some values that bug out sometimes. There’s a value that checks if the packing is running, sometimes it bugs out and if you save the file it also saves the bugged state into the file.

Yeah it seems to be a problem baked into the .blend as a fresh one works fine. Sadly updating stats, saving and reloading also doesn’t fix it, I guess I can just copy my assets into a fresh file! If I get the error code again I will make sure to post it here

I’m getting an issue with shotpacker, it keeps crashing when I try to pack with the following error https://gyazo.com/58697926da69c41dedb642eb15be5d4e

And then the packing hangs on 5% like so: https://gyazo.com/9967830cb85359e62072479944bba36e
Any help would be greatly appreciated as I don’t know how to fix this.

I’ve tried removing the addon, adding it back, restarting blender/my pc. I’ve tried to look for loose geometry but can’t find any. Tried the update stats button to no avail. I’ve also tried a new blender scene which worked for a while but now it’s broken again.

Hi, can you send me a .blend file where this failure occurs?

If not, you can also comment out all the ‘assert’ errors in the code, or delete the line where there is ‘assert’. Just open the file and delete the line where the assert is. Asserts are there to break the program if something returns unexpected values, but it may still work if they are commented out or removed.

Hi,

Sorry been a busy week, this link should let you download a blend file with the error in it. I hope it helps with troubleshooting.

I’ll give the commenting a go, If you find anything wrong with the mesh thats causing the issue, if love to know!