UV Painting on wrong face

So I’m trying to texture paint some hair, but for some reason when I paint, it’s showing up on wrong faces, even though I’ve checked to make sure the UV islands are not overlapping. To make it easier to see I tested this with a red color.

Here’s the face I want it on.
image

And here is the back where it is showing up where I don’t want it to.
image

And here is the UV map for those two sections.
image

What’s even stranger is that if I go back and completely cover the base texture in the original color via the uv map module, then paint on the mesh itself like normal again, it’s no longer painting on the wrong faces.
image

image
image

If both of these toggles are off you will paint on the opposite side of the mesh. Maybe that’s why.


https://docs.blender.org/manual/en/latest/sculpt_paint/texture_paint/tool_settings/options.html

Hmm, I tried turning both of them on and then having each one separately on. But this didn’t work.


image
image

You have flipped normals: turn Face Orientation on in your Viewport Overlays, select all red faces, Mesh menu > Normals > Flip

1 Like

@josephhansen is probably right but it is possible you have symmetry on as well.

3 Likes

It was the symmetry. :person_facepalming:
I feel stupid for not realizing that, but at least it’s resolved now! :laughing:
Thanks for your help! Thank you @josephhansen as well!

1 Like