UV Pins not working?

I’ve been following this tutorial and it came to the point where the author is doing skin pinning. I have tried this myself, and it is not working. When I select a pin to move, all that happens is that one vertex moves, instead of the whole mesh. Any thoughts? Pic included - the problem area is highlighted in red.


Ensure you have ‘Live Unwrap’ enabled

Yep, I checked it - it is enabled. Any other ideas?

Supply a Blend file that demonstrates the problem

Here it is. The attachment manager here had errors uploading it.

I hate all those waiting and advertisements all around. In future please paste your .blend file into http://pasteall.org/ This will take a second.

The problem that i m having with your model is that your model’s UV is not a whole the vertices are all separated i tried to weld them one after other they somehow get separated when i m moving on. I will give some more try later on. One think that you should is that the live uv unwrap feature works only vertices are connected. If you want to see that feature working then try an other model but if you want to manipulate your UV you can try to use proportional editing tool and play along.
Keep blending :wink:

Ok, I tried it on another, continuous mesh, and am still having the same problem. File attached.

pinned-cube-problem.blend (478 KB)

I’m thinking maybe this is a problem specific to the newest blender version - multiple sources seem to think this should be working.

A question before making any conclusion: how do to you unwrap your cube? I try to unwrap it get the same result but it is impossible, since you have not any seams, how to you do that?

How are you unwrapping ?

From your last blend file, your unwrap doesn’t work with live unwrap. If I add seams and create a new UVs the live unwrap works correctly (blender 2.72b)

Just second what Richard had said and emphasis what i have said on post #7 your uv map should be whole since from the unwrapping section if you set sticky selection mode to disable you will see that your uv map is not continuous.

I don’t remeber how I unwrapped it - I think i just did a smart unwrap, and then I connected the edges using stitch. After using a seam it worked, though not really how I expected it to…

Can you send a blend file with this working correctly?

It seems continuous to me. Shouldn’t the stitching have solved that problem?

Can you send a blend file with this working correctly?
See the attached file. Use seams and U / Unwrap for it to work


pinned-cube-good.blend (492 KB)

Oh i see how you did it. I think I have to use more strategic seams next time. I’ll look into that.