UV seams visible in render

I am working on an animation, where my dino is walking through. when i am in closeup view, skin texture looks fine and in camera with some far distance, it renders the UV seams.
i textured in Zbrush. i have also checked the model and texture UV borders etc.,everything seem fine.
PFA image below.
Please provide your solutions.

I know you said you checked the borders, but okay close, bad far sounds like borders. How’s it look when you changing filtering to closest?

No…filter type tried to change closest…no luck…

It is a problem with your margins in the texture you painted. In rasterizing real time rendering engines, when the camera moves away from a texture the renderer down sizes the texture to a smaller size to save memory. Of course, since the camera is far away, the difference in the resolution will not be noticeable at all.

Since when a texture is downsized, the pixels have to interpolate the surrounding pixels values, then pixels at the borders of the UV seams will include transparent or black pixels in their interpolation, causing them to have a darker or brighter color than they should be. This is probably the problem you are having.

Here is a picture illustrating this concept (open the picture and zoom to notice the difference):

Also, here is a link with even better explanation from cgcookie: https://youtu.be/BCfh7xWCc5w?t=254

To fix this problem, you should add an extra margin for your textures around the UV islands, this is usually done during the texture painting stage where most tools (including blender, but not sure about ZBrush) include options to automatically add extra bleed at the borders to prevent such issues. In your case, you may search for a tool that generates borders around your already painted islands, I am sure you will find something useful in photoshop or gimp.

I am not very sure, but theses broders will probably not be visible in a path tracing engine such as Cycles. Maybe you can try rendering it from a distance in Cycles and tell us what you find.

If it was borders, filtering to closest should have fixed it. (Not that anybody should be using closest filtering, it’s just a diagnostic fix that comes with its own problems.) So, I guess it’s not that, no matter how much it sounds like it. I’m afraid I’d have to see a file (with packed texture image) to tell your more.

I have found the solution partially.

  1. UV map border settings needed to check in zbrush - Increased the values of the map border removes the black lines and the artifacts.
  2. Displacement map from Zbrush still creates the UV seams

Here i have attached only connected with the texture map.Though i got the black areas and seams visible in the texture map, by applying the"subdivision surface modifier > sharp" settings removes the seams and the black areas. But multi resolution modifier doesn’t do the trick.

Now i need to work on with the displacement settings in Zbrush.
I will let you know the updates. Also welcome solutions from your side.
Thank you @bandages @okm1123


Hello guys,
I solved the problem with the texture map but i couldn’t able to find what causes visible seam in displacement map. So i decided to go on with the normal map, which is working fine.