UV Text Question

Hopefully there is a simple answer … :spin:

I have a UV Text Map that I created and am trying to use for in-game text. I’ve loaded the file and mapped the “@” character. However, instead of seeing “Test Message” from the String - Text property, I see a “@@@@@@@@@@@@”. I’m thinking this is file problem because I have other text map files that work fine. The only visible sign I notice is when I set the boundaries for the “@” within the UV map for a working text, the background in the 3D view is grey. For the file I’m attempting to use, it’s black.

Any ideas on what the problem is? Or how to correct? Thanks!


Seems to me it has to be in the bricks, if I understand correctly - you’re getting the “@” symbol to show up when you hit “p”, which means it’s textured properly, it just isn’t tiling correctly, which is what the game engine text settings do for you - leading me to believe that the logic is somehow off. Tell ya what: post a screen of the GE setup and of the texture setup, just to be sure.

Appreciate the help …

First file contains the Texture Settings and the Working UV Arial font …

All settings remain the same and I create a new IM for the 2nd font and load the .tga file. If you look at the pick-list, you’ll notice that some of the images have a light ICON background and some of them have a black ICON background. The light ones work fine … but the black ones don’t (which is why I think it may be a file issue).

As for the GE settings … hmmmm … being N2B, I’m not sure what settings you’re referring to … I’m still progressing through a bunch of tutorials and haven’t run across a GE Settings menu. Can you elaborate …



Sorry it took me so long to get back at ya. OK, here’s the tut you need. The game engine settings are accessible by hitting the little “pacman” button. You need to give your plane the “text” property.

Hmmm … sometimes I hate forums because they just can’t quite capture the “essence” of a problem. I appreciate the link - that’s the tutorial I used to set up the Arial font that works initially.

If you look at the 2 thumbnail images above, you’ll notice the left one works (e.g. the Arial font) - notice the “Message Test” … but the right one doesn’t (e.g. the Parchment font that I “attempted” to create as a .tga file) - notice the “@@@@@@@@@@”.

The only difference is that I attempted to load a new UV Text Font file. All other settings are identical - including the plane which is the same in both examples and has a String Property set to Text. The file visibly looks the same in the UV window once loaded, but if you look closely at the ICONs beside the IM pick list, you’ll notice some are light and some are dark. I think that this is an indication that the file background may not be set up correctly.

ok … gotta go get a bandaid from beating my head against the wall … LOL … any other insights?


You’re so right about the forum being a tough place to resolve issues - so much information gets lost in translation.

Just on a hunch: you didn’t happen to get rid of the odd pixilated stuff (looks like a mistake or an error) at the top left of the font image, did you? I understand that can be a problem, the text engine needs it to read the image.

It sounds the new texture has destroyed font information. This can happen, when the image is converted, scaled, cropped or other content changing operation is applied. You should make sure you have a valid font texture or create a new one with FTBlender. On the resulting image you should not change the top bitmap content (the little white dots). You can change the letters, but make sure you save the same format as before (no *.gif no *.jpg)

I hope this helps

Um … Ok … don’t SHOOT me … :smiley: … but your last post promted me to do some more research … and you’re right … the data at the top of the image is missing. Why? Because it wasn’t there to begin with. DOH! :eek:

I told you this was a self-created file and I have never worked with font files before. I didn’t realize the file was anything more than white text on a black background, so I created one by using a standard editor with white text and a black background and then saved as a .tga file. Geeze - do I feel stupid :spin:… that answers the question of why the pick list was showing up different - because Blender was interpreting the file as a standard image and not a Font file.

Bottom line … downloaded a .tga font file converter, re-created and loaded, now everything works fine. Sorry to have taken up your time :frowning: , but I really appreciate the feedback and sounding board.


Bingo, problem solved. Actually, New2Blndr, no question is a waste of time, because someone will come up with exactly the same problem as you’re having, do a quick search here, and have an answer for the problem, thanks to this little convo we’ve all had here. Just glad it worked out!