UV Texture not working..

I’ve about torn out enough of my hair to go bold with this problem. I haven’t a clue why this is happening, but for my current ship project I created a custom texture to use to give the impression that this ship was made from various pieces. The problem? Despite being UV unmapped, and despite having nodes to place the texture and have it attached to the displacement tag, the texture is NOT showing up.

This has me rather annoyed, since I’ve done this process a dozen times already with OTHER projects (and just recently did a test project just to see if I was doing something wrong, got a cube, UV unwrapped it, loaded up Gimp 2 after saving the UV map and then messed around with, once I was done I exported that texture and then loaded it up into blender… attached it to the Cube and it works) yet, for some reason… it won’t work now for my current mesh, even though the PREVIEW clearly shows that the displacement texture is there, according to the viewport render, it isn’t.

It is driving me nuts trying to figure out why the displacement texture is working on one of my projects, yet isn’t working on this? (I’ve double checked to make sure I did the node-set up right. Don’t suppose anyone might have an idea of what is going on?


I would rather see a node setup and your object data panel, but what I suspect is that you need to use an attribute node with the proper UV map labled.
Edit in with an example screenshot:

I tried the attribute tag you used and renamed the UV Map; however, it doesn’t seem to be doing anything =(

Here’s a new image, showing the node set up (I’m not using the main material, I’m using a material that has less items in it just to try and fix the problem, but even the test material has the same issue)


Replace that color mix node with a math node and set it to multiply.

Nope, that doesn’t work either… mm… did you want me to post the .blend file along with the texture I am using?

What is this cube object and should it have scale 3? Just to be sure - have you applied scale to object?
And i second changing to math Multiply instead of color mix for bump.

Yes, also, are you letting it run for more than 10 samples?


Yes, I had it set to one hundred samples in preview. Also, as for scale, I typically use the shortcut (S Key) to scale my objects, rarely do I ever use the actual panel itself.

Anywho, here’s the .blend along with the displacement texture I am using.


Light Carrier.blend (1.84 MB)

Wow…you really had that scene all messed up imo…
You had that model so huge…
I have resized the model and got it working. I rendered on the cpu, so we will know if thats an issue.
Any reason in particular that you had that model so huge?
Use my blend file and just reset the image location. i didnt pack the file.

light_carrier_fixed.blend (1.65 MB)
Also, your render settings are all jacked. You dont need 128 diffuse bounces leave that at default, I see no need for the glossy filter. i would just leave that alone also, I would leave the clamp setting alone unless you really need it. Set that back to zero.

I typically start a model out large (mostly because of the grid, if I start out to small then I have problems making refinments) but once the model is completely done then I return its size down what it should be.

And this is odd, downloaded your fix but once I load it up, UV mapping is not working now (won’t load up an image) nor does it appear that the texture map is even active… ughs… now I’m strating to wonder if my Blender is messing up.

Did you reload the image?

Yep, tried that :frowning:

I would try a different build then. Something is wrong for it to work on my pc and then not yours.

I don’t think its the build; like I said earlier, I have no problems with the displacement map in my other projects, it just seems to be THIS project that has the problem. I’ll see if I can append the model into new project and rework the UV Mapping later today (as I switched to another project for the time being)