UV unwrap messed up on some objects.

I’m trying to unwrap my submarine and something’s going wrong. I tried removing seams and placing them somewhere else, putting them all around, but I still get this weird unwrapping. The strange thing is that unwrapping other objects like the support or the pipes goes right. Only the bridge and the body are acting weird.

I checked different settings but can’t seem to find the problem. I’m getting desperate.

The blend file for the scene: https://drive.google.com/file/d/0B-nMz86YPRC9cUFfSmdoQTNwalU/view?usp=sharing


Did you try a different unwrapping method?

You can unwrap it in parts, if you have to. Just select the faces you want to work on and unwrap them. It might even be easier that way to organize the map into islands.

No, I just use the unwrap command. Nothing special for I know. But I must have switches some option on or off. But as I said: the strange thing is that it’s only the submarine who’s getting strange unwrapping.

smart unwrap and project from view are giving a nice unwrap. But I really like to know why my unwrap gives this weird result. There has to be something I do wrong and I really like to know what.

Ok, I still don’t know what I did wrong but I deleted the UV map and now everything is back to normal.