uv unwrap proportions help!

I don’t have much experience texturing models, so mind the fact this is probably a simple problem. I’d like to put an image (logo) on part of my mesh, but I’m having trouble unwrapping. This is what the proportions look like when unwrapped:


In order to achieve this, I:

  • Marked a few seams
  • Selected the mesh
  • Pressed U > Unwrap

As you can see, the projected proportions are way off. I tried switching from angle based to conformal, but the proportions are still off! I feel like I am missing a major step when unwrapping a mesh!

On a side note, I was wondering if you can have multiple images for different parts of a mesh, or can you only have one image per mesh. Thanks for all the help!

Well, if those faces are the only ones you are going to unwrap for the logo, here is what I suggest:
-Unwrapping using the “Cylinder From View” option.

      -Load a test grid for your texture into the UV editor. Either the built in generated grid (Image     properties>>Generated>>Test Grid), or a custom image, which I have attached.

 -Enter Textured Viewport Shading (ALT-Z) in your 3d view to see what affect your UV map is     having on the model.

-(If necessary) Adjust your UV Layout until the grid pattern on your model in the 3d view is evenly distributed and undistorted.


Thanks, I’ll try this out.

I’m surprised there isn’t a way to project your UV’s proportionally… I thought that in reality, when you unwrap, your are flattening the mesh. I can see in most cases, it is more important to have the image unwrapped cleanly and sacrifice proportions, but in circumstances like mine, it would be nice to have UVs proportional.

Try selecting only those faces and then unwrap (conformal) If they turn out correct, then your seams need major work.

Yes you can have faces using different images.

Also, “Conformal” is supposed to do a better job of keeping the UVs proportional, obviously nothing’s perfect. :slight_smile:
Well, I tried setting up a cylinder and a rectangular box with the same spaced edge loops you have there, neither of the “from view” projections are going to do what you wanted, however, the Unwrap worked perfectly with proper proportions for me.
As Waternz said, only select the faces you want to unwrap.

Sorry to bring up an old topic, but I’ve just recently been able to test this out. I’ve got the image in the correct position, but it is now scrambled all over the rest of the model too. This is what it looks like…


The “MM” is in proportion on the spot it should be, but the image is also being copied on all of the other polygons. Here’s a screenshot after selecting the entire model:


What I did to get here:
-selected the section I wanted the image to be on and created a seam
-unwrapped just that part of the model
-opened the image, and stretched the uv vertices to match the image.
-added an image texture, loaded the image.
-in the “map input” tab, selected UV instead of ORCO.

I haven’t created any other seems, but how would I get the image “MM” to only display on the part of the model I want it to?

And also, I don’t understand why objects that weren’t connected to the mesh recieved the texture too. All of the pegs at the top are completely separate, yet they also have the MM image attatched…
(Edit: Figured this one out… had to click the “Make Texture Single User” button next to the texture name.)


Leave the MM polys as they are. Create a new material, make sure it doesn’t use a uv mapped texture and asign to all the other faces.