Vectorworks to Blender

Does anyone know a good way to get a Vectorworks 3D model into Blender?
I currently model in Vectorworks 2009 and then export to an old version of Artlantis render 4.5 to texture and render.
My boss is tight and wont spend anything on software. I’m not really up to speed yet but i’d love to bring an old model into Blender to light and render but none of vectorworks export option seem to show up on Blenders import options. Anyone managed this before?

Import DXF ? Enable the addon in the User Preferences / Addons panel

See for the supported data

Thanks. I’m stuck on OS10.4 at work so the latest blender i can use is 2.56 and the importers not worked great for me so far.
I’ll try on my 2.62 at home tonight of maybe push someone off the newer machines here.

I tried importing a dxf from Vectorworks but no luck. I get this error,

ValueError: invalid literal for int() with base 10: ‘Autocad Binary DXF’
location:<unknown location>:-1
location:<unknown location>:-1

(I think i copied the right bit.) Any ideas?

Here’s what the BLender DXF importer will support (from the wiki):

supported data:

  • 3DFACE, SOLID, TRACE: as mesh-faces
  • LINE: as mesh-edge or curve-segment
  • ARC, CIRCLE, ELLIPSE: as segmented polyline
  • entity properties: THICKNESS
  • entity 2d-rotation (e.g. by TEXT)
  • entity 3d-orientation (210 group)

partially supported data:

  • TEXT (missing adjusted data)
  • LWPOLYLINE, POLYLINE: as segmented polyline, but missing: width, spline, bulge, thickness.
  • POLYFACE / POLYMESH: as polyline/wire, but missing faces.

unsupported data:

  • entities: 3DSOLID, DIM, XLINE, REGION
  • hierarchies: BLOCK, INSERT, GROUP

If your source contains any of the partially or un-supported data types, you need to convert them, or e.g. explode all blocks, regions, un-group all groups, etc.

In addition to what Ran13 mentioned, your dxf file must be in ASCII format. (As opposed to binary format)

There is a nice free tool that can convert between almost every possible version of dwg, dxf - ASCII and dxf - binary.

Thanks for the replies.
I think i had some groups and querky vectorworks solids. I’ve been trying with just basic extruded polygons but i still get the same error. I have to export a DXF from Vectorworks and it throws up a load of options. Is there a preferred version of autocad to choose?, i think i get to pick from v14 to about v2009.
There is also a choice between DXF(binary) or DXF (text) which sounds like what you mentioned FishB8. Thanks for the link, sounds very useful.