Vertex paint only shows in edit mode

I can only see the vertex painting results when I go into edit mode, and never when in actual vertex painting mode, like this

and in edit mode

Apparently I can paint, but it’s just not showing on my model. Also doesn’t render with the colors.

I also had a problem about not seeing the effect of weight painting, the model remained blue no matter what i painted on, but when moving the armature the weights were obviously applied. Is this a bug? Am I doing something wrong?

If you want the vertex paint to show in the render you will need to enable the Options / Vertex Color Paint option in its material settings

Supply your blend file

Oh, it’s not a bug, I’m just a moron, the vertex color paint option is what I was looking for, thank you,