Video Renders As Massive File!

I am working on an online ad for my company. I created a 30 second video without audio. I rendered it as images and then put the images back into the Blender video editor and rendered it as an AVI video.
It renders fine, but the 30 second video is 4.9GB!
I don’t see any reason for this. It was rendered in the standard 720p definition.

What did I do wrong?

You probably have your output set to uncompressed.

What exact output settings did you use.

Read the manual for details on the available formats

Use a compressed format such as h264, xvid etc

There is no compression setting for AVI Raw.

I am using AVI Raw output at 1080p quality (not 720p like I originally said).
The strange thing is that when I render a similar animation on my other computer using the same settings, it’s only 18mb.
When I pass the video through the Freemake Video Converter and convert it to the same output as the original file, it will shrink down to 18mb.

That’s because AVI Raw is an uncompressed format.