Video texture length issue...

I originally put this in the Blender General forum but it didn’t get any replies! Here’s the problem:

I’ve made a little robot that has a TV screen for a face… I’ve recorded a short video of my face and have applied it as a texture to the screen. The video I want to apply to the screen is 122 Frames long… When it loads into Blender it shows as 146. When trying to sync the Blendered video with the audio from the original it runs out of sync as the new video is longer than the original audio.

Any suggestions on how to fix this?


I’m no expert but it sound to me that it has something to do with frame rate. There are more frames in your video and because there are more frames/second the blender converts it to match the default (25 frames/second). Isn’t NTCS-format 30 frames/second? I can’t think of any other solution… It could help…


perhaps you could use a chromakey plug-in…

Well, first off… Thanks for the replies! I’ve been scratching my head about this for a while and have not had any help…

K-Lo - I don’t understand why Blender would try and change the frame rate… 146 doesn’t fit with 30fps any better than 25fps would.

MMOAdude - What would a chromakey plug-in have to do with syncing the frame rate??? It doesn’t make any sense to me.


sorry, I meant that you could use chromakey to put your anim. on the TV screen instead of putting it directly on the screen as a texture. But you might not get as good of am effect.


did you check the framerate? If your video has a different frame rate than what has been set in Blender of course it could cause this. The sound has no frames/second modifier. It’s just seconds. 146 is 24 frames bigger than 122 - and 24frames/seconds is PAL. If you have even one frames less (like say 25frames/second) it makes a difference. 122 frames is 5.08 seconds with PAL 24frames/second, 4.88 seconds on default 25frames/sec and 4,066 seconds on 30 frames/sec with NTCS. That would explain why you have more frames than what you originally have and the video goes on after the sound.


MMOAdude - I see what you mean, but I want to be able to rotate it’s head and move it without the hassle of matching a separate video to a blue face.

K-Lo - I understand what you are saying now. The video I am trying to bring into Blender is 25fps (PAL). There doesn’t seem to be any import options. The only place I can see that has anything to do with the frame rate in Blender is in the rendering options which obviously won’t enable any changes to be made to the 146 total frames.

i see what you mean…doing the frame-rate thing will give you better flexibility.