View and Camera problems....

Hya!

I don’t know how this is supposed to work so I don’t know if its even a problem or not (actually it is a problem because its making me pissy).
In both the normal 3D view and the camera view with “camera locked to view” if I try to zoom in on something, like for example I am working on a person and want to look at the hand, at a certain point the view/camera begins to slow down and basically stops. I can neither move in or out, or side to side until I zoom out again. On the other end of this and this is just as annoying, if I make an object larger it begins to vanish like there is an invisible wall around it, this happens also if I zoom out to far, but thats harder to describe.
This has happened for a long time (many years) not just the current versions of Blender.
Also I am using 2.69 at the moment in case that is relevant.

Anyhow, thanks for any help on this!

Cheers!
Mealea

1 Like

I got this problem in the past in an older version, but never managed to reproduce it so i couldn’t report it.

What you can try when it happens is one of the following :

  • switch to Ortho or Perspective view depending on which one you were in.
  • select an object or at least a different one from which you’re viewing if you can and press Numpad - (or click on View -> Align View -> View Selected) , sometime it can get you unstuck from where you are
  • press SHIFT + C , it centers the cursor and get the view back so you view all the objects.

Ideally if you can get this happening again, please save your blend and upload it somewhere, so it can get reported to the devs

For the vanishing objects, if it’s very large it can happen that the view clipping default settings aren’t enough for it, press N and scroll down to change the values and see if it helps :
http://i.imgur.com/nogEdlT.jpg

1 Like

when you get too close to an object the perspective camera can’t work out the perspective properly so it goes all slow and crappy. i don’t knwo if its a bug or if thats just how its designed but anyhow switching to orthgraphic camera eliminates the problem. as for the object dissapearing, thats just the camera clipping value. open the camera data and change the max clipping value to something large and your model will re appear

On the default cube scene of blender.

  1. num 5 for perspective view. Everything works fine, zooming is OK.
  2. SHIFT+C. Now the issue is back. Zooming is in trouble.
  3. View -> Align View -> View Selected [CTRL+.]. Now it works again.

@Sanctuary
I tried to save the file.
The problem is, when I reopen it, works just fine LOL
Metaphysics.

However, the steps I posted are valid, try it.

@Mealea and other friends.
When this nasty thing happens, CTRL+.
happy blending. he he

edit:
reported as bug, let’s see now
https://developer.blender.org/T39175?workflow=create

Good, i’ll post a bug report with your method to reproduce the problem, as i doubt it is supposed to make this with SHIFT C

edit : i reported it
https://developer.blender.org/T39176

edit 2 : oh looks like you were faster :smiley:

reported already
(posting same time, sorry)

On a sculpt of mine, tried to trigger it by shift+C.
The first time it happened, ctrl+. stopped it.
I tried it again but this time can’t reproduce the issue.

well I know one thing only.
Ctrl+. is the solution when it happens.

Ok I got it to happen again but the resulting file is several hundred megabytes…
I tried all the suggestions above and none worked, interestingly however while trying to zoom in on a hand in perspective, switching to orthographic launches me right up the armpit, thankfully its not a human figure or I would have armpit stubble in my face.
Im going to decimate the hell out of this file and try again to see what happens.

The clipping thing is next.

Thanks you guys!!!

So…
The decimated version I can zoom in on with no problem… aside from what I will call inward clipping for lack of a better description, it looks like the large clipping I mentioned but this is while zooming in.
My guess, and its just a guess is that Small Troll is correct and that Blender can’t cope with the high polygon mesh [EDIT: with perspective] but just sends me inside of the low polygon mesh… or something like that…

Now I will screw with clipping to see if that fixes anything, but this brings up the question, how do you do things like small details if you can’t zoom way in?

Decimation versions etc are irrelevant
No, it is a bug, unfortunately devs have a different opinion.

Try a simple [.] on num pad next time.
To save the blend file and upload it won’t help at all.
If I reopen the blend, the issue isn’t there.

. just zooms out a lot mostly but zooming back in still doesn’t work.
Also the decimation thing is not working (you are correct), I stopped being able to zoom in later after trying to work on it.
I shouldn’t have to do that anyway even if it did work.
Also saving has no effect, it still happens on new things, imported things, .blend files, things made in Blender, and things made in other programs. Sometimes its hard to zoom in on the default cube but thats sort of rare and hard to reproduce. Basicly anything and everything. But not always.

I looked at what the devs said and unless I am mistaken they are saying that I am zooming in on the wrong center of rotation or object center or something to that effect.
So…
What does that mean?
I can’t work on what I have selected? That sounds challenging.
Or do I have to make a new object that is more convenient for zooming somewhere else and zoom in and or rotate around this new object to keep working?!?! Thats not just challenging, thats insane and I am (sort of) amazed I even thought of it.
How do I change the center of zoom or rotation or what ever this problem is caused by every time I do something? That is what would need to happen for example if I wanted to rig fingers and toes, something I cannot do now because I can’t get close enough MOST of the time.
If its not a bug why does it not happen all the time? Why just some of the time? If my word processor decided that I was not allowed to type at random, and for no good reason, I would consider that to be a bug, not a feature.

“not a bug” ? really ? a manipulation that will make the user completely stuck , unable to zoom or pan anymore (unless they press numpad . or ctrl . that are shortcuts for the same function Align View -> View Selected ), and that’s not a bug and so no need to fix ?

Sometime i really don’t understand the bug tracker then.

For now the best thing i can recommend is to never use shift + C (or its function View -> Align View -> Center Cursor and View All) , even if it’s “not a bug” , it’s clearly not functionning correctly when you use it after zooming.

But still it’s concerning that more beginners will not know about this, will then probably use this view function one day and they will become stuck too without knowing how to get out of that problem .

Thanks Sanctuary… I agree.

The thing is also that I almost never use any of those commands, I tried them since they came up in this thread but they not only didn’t help they made things more aggravating, after a LONG zoom in the “.” key zooms me back out! That is the exact opposite of what I was after and zooming back in took just as long and never got where I wanted to end up.
If its not a bug its a very bad feature, and since its a feature, where is the OFF SWITCH?
You are more than correct about new users, if someone tries to learn something and it simply doesn’t work or make sense they don’t learn it and its not their fault.

By the way, Im looking at your stuff with the skin modifier in your sketchbook, and I learned a lot!!! ITS VERY COOL, THANK YOU!!

thanks !
I keep that thread around instead of removing it despite i don’t use it and i’m not interested in updating it anymore, so i can refer to my older sculpt work to check if i improved on some part or regressed, i still have a lot of work to get to your level :wink:

Think it this way.
You are sitting at a park bench with a pair of binoculars Birdwatching :).
You can zoom up to a certain point but you wish to have a better view of the bird in the tree.
So you get up and walk closer to the tree right?.

Same thing with the blender viewport , you can oly zoom the view* ( consider the viewport as a camera), so that’s when the numpad dot(.) comes in, it moves the view(camera) closer to the selected object.

If you model through a camera (numpad 0) you won’t have this problem because when you zoom you are altering the cameras location which is not the case when you model in the viewport unless you hit numpad dot(.) to change the view’s location.

I might be totally wrong but thats how it seems to behave.

@RamboBlender:
hehehe!!!
Try as I might my attempts to use binoculars to build a bird have always failed! I get feathers stuck in the lens and see parts of the bird never meant to be seen outside of a carnivorous animals lunch or a kitchen! Not to mention the stuff on windshields.
Besides, most birds do not possess forcefields that prevent further zooming, if they did the military would commandeer them.
The “.” zooms me WAY OUT, not in and it does in the regular viewport, the cameras viewport and in both perspective and orthographic modes. But not all the time…
In short, most of the time I cannot work in high detail and when I do I’m afraid to move as I might lose the ability at any time…

@Sanctuary:
My level?
HA!
You are WAY past that!!!
Thank you though, that is truly sweet and deeply flattering!

@ramboblender I think you’re overlooking the point .

Load blender, default factory setting
Now select your default cube, press S and type 0.01 so your 2meters x 2 meters x 2 meters cube become a 2cm x 2cm x 2cm cube.

Make sure you’re in perspective mode, now zoom until you get very close to that small cube (as if you wanted to add details on it) but stop before the default view clipping butcher it
That will put you roughly there
http://i.imgur.com/HFqRgaz.jpg

Now press SHIFT+C and now zoom toward the cube again.
You’ll notice the zoom stop here, you can’t zoom more than that, and the more you try to zoom in, the longer it will take for you to zoom out
http://i.imgur.com/Yn0OuuJ.jpg

That’s already something, but now try to pan the view … huh ? yes that’s the problem, you’re stuck the view panning does not work anymore.

Click numpad 1 or 7 or 3 to change view … still panning the view is still not working …

I can’t understand when a very basic view command (panning) is not working anymore despite it should can be called “not a bug”, so if it’s really not a bug and it’s intended for the panning to suddenly cease to work, i completely agree with MealeaYing, it’s a very bad feature.

By pressing Shift+C you are now placing the Viewport (camera) farther way than it was in the start-up file hence you cant zoom to your scaled object after a certain point.

Try this.
Load factory settings don’t scale the cube and hit Shift+C and see what happens.

Panning won’t work because now you are farther way from the object while in full zoom.

Like I said we need to move close to the object and not zoom at it from farther way.

I guess what i’m saying is we can only zoom from the Viewport (camera), so we need to pres numpad dot(.) or numpad slash (/) to fisically move the Viewport (camera) closer to the object.

That’s how I see it, like I said before I might be totally wrong.

Ok… this is too confusing, I want to draw, not destroy my keyboard.

So, what I have done is whipped up a little example.
Try zooming in or panning around in either viewport, one is normal 3D view, the other is the camera.
Heres a .Blend file:
https://dl.dropboxusercontent.com/u/76310757/BlenderisticThingermerbobs/BadFeatureRollOverAndPlayDead.zip

There is another problem with this scene but I will get to that later, it’s less fun.

Oh I see!!!
Go to preferences/interface please uncheck “camera parent lock”
Save your prefs.

BTW, your lighting set up is quite out.
Try to avoid these boxes around, you don’t really need it.
This is another discussion, will explain later.

Ok but its not just the camera…
Hang on…
Ok I just did that, it didn’t change anything.

Now what?