view troubles?!!?!?

ok, so i am doing my work and everything is going good. but when i orbit around the scene, half of it gets cut off! so when i orbit around, only a sliver of the mesh shows, and if i zoom out too far, the whole scene disappears! how do i fix this? does it involve something with the view settings? help please!:spin:

Open the View / View Properties panel. Increase the View Camera Clip End value. So you don’t see the same effect when you render, select your camera and in the Camera settings also increase the Clipping End value

or just make ur mesh smaller? I never understand why people make things so huge.

OMG! thank you so much! this help alot

thankis alot richard