Viewport clipping problem


I have a long time issue with the viewport clipping. When I am working around a model suddenly starts to disappear from my view. I know that I have to go to View panel and change the Clip start-end. Lets say the end value from 1000mm goes to 1500mm. For a while eveything is working perfect. After some moments the model starts to disappear again. I repeat the same method. From 1500mm goes to 2000mm. Again for a while everything good. The problem is that I repeat this process always ( up to 6000mm) and my model after a while continues to disappear. The biggest problem is that when I am working on edit mode and I have the end Clip to 6000mm is very confusing to see exactly the faces and vertices of the model. The solution that I found is to Lock the view to my model but then the zoom in and out and rotate does not work properly.
Is there something that I have to change on the system preferences or only the start-end Clip.
Can someone give a solution because is really annoying.

I dont know how this really happens.

But for a fix i think you could add a key frame of how much you really want. then it shouldnt change. even if it change it should go back to the keyed value youve assigned.

if its a small object u can have it the lowest. and right click and select insert keyframe

Hi, thanks for your answer. I will try to make this. But I am really confused with this issue. I am using Blender for almost 9 years and I always had this problem. I have searched around and the solution is to change the end or start clip. But after a while this visibility problem comes again. At least in my case, because I haven’t seen someone else with this issue. I am wondering if has to do something with system preferences. Anyway I hope there will be a solution.

Yeah its pretty strange

And you can try downloading different versions of blender and see if it exists in those as well.

I suggest that you add this issue in “and Report a Bug option”

They are normally quick to respond. Make sure u attach your full system information to your report by uploading the file saved by Help > Save System Info in Blender.

I have been using all official blender versions for some years now and I have the same issue. But no one else have this. So I thought that is something with my settings.

I will report it like you suggested. Thanks for your reply.

1 Like