Viewport Playback is Slowing Down

Hey there! It’s been a while.

I’m having trouble with Eevee at the moment, which is strange because Eevee has made my workflow for this project much faster in general. I gave an old scene a face lift and put quite a few characters in it. It’s a far cry from a complex scene, the geometry is pretty low (about 1 mil faces). I applied all the subsurf modifiers I could find, when I hit the playback button I’m still getting 5 fps, and it seems to be getting slower as I go. I’ve tried isolating some of the elements to test what’s causing the issue, but nothing seems to be improving despite the fact I can navigate pretty easily. It’s definitely the characters that are slowing things down, but it doesn’t seem to be any one character. I have a fight scene coming up, so I need it to be running more smooth than this.

Any help? I’ve provided the project file in the DropBox below:

You don’t want to apply the Subsurf modifiers, you’ll want to turn off all the Subsurf. Applying them is the same as having all modifiers on, but now it’s permanent.

You need to go back to a saved version before you applied the subsurf and just turn each one off, or use the simplify option.

Tim

I see, thanks for letting me know! My experience before was that applying them greatly boosted my performance, so I thought that was the case here too. I’ll simplify the characters that aren’t important. Thanks!

1 Like