Viewport render differant to actual render. Help needed

I need the rendered image to look like the viewport render. How do I do this?
Blend file:

Welcome to Blender, where a Viewport render does not always mimic a F12 one…

I had a very quick look, and it seems your shader is going wrong somewhere. Don’t have time to look into this further though…

Also, the scene renders really slow for such a simple setup.

You have a sun lamp and a cube disabled in viewport but not in render. You have to disable them for render aswell.
In the outliner display the icon to disable in render by clicking the icon that looks a bit like a funnel and choosing the icon that looks like a camera. Then disable the cube and sun lamp for render by clicking the camera icon.
It will render as you want:

Edit: the scene takes a while to render because of the volume absorption but that is normal

1 Like